Slowest turbo Miata ever - Page 35 - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 03-10-2015, 06:39 PM   #681
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Maybe just an itty bitty more meat.


Took it around the block. My god, i forgot how damn awesome this car sounded. Not that it's fast, but when you've been daily driving a 100hp miata all winter, it feels like a rocket ship.


REALLY wish i had coilovers to get a nice fitment.


It should look really good maybe another 1" to 1.25" lower. Plus it's been sitting on stands for 6+ months, so the springs will probably settle down at least another half inch. I'll be leaving it on the ground for a week or so.








I got some fender work to do anyway... The plan was to have my TECNA coilovers so that way i would have the suspension off the car for test fitment then install the new stuff... Not sure how to do this now.
Attached Thumbnails
Slowest turbo Miata ever-dsc06121.jpg   Slowest turbo Miata ever-dsc06122.jpg   Slowest turbo Miata ever-dsc06123.jpg   Slowest turbo Miata ever-dsc06125.jpg   Slowest turbo Miata ever-dsc06124.jpg  

Slowest turbo Miata ever-dsc06126.jpg   Slowest turbo Miata ever-dsc06127.jpg  
Erat is offline   Reply With Quote
Old 03-21-2015, 10:16 PM   #682
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Did i install my DW fuel pump incorrectly / is it faulty?

When i key over or if i jump it to ground it builds pressure (set at just below 60psi), but when i shut the pump off, it quickly falls to zero.

I remember the stock pump holding fuel pressure for at least 24 hours.
I found this thread, doesn't seem like my issue though.

Is this normal?
Erat is offline   Reply With Quote
Old 03-21-2015, 10:17 PM   #683
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: woosta, ma
Posts: 8,684
Total Cats: 93
Default

is the dw supposed to have a check valve? And did you change fuel pressure regulators?
Leafy is offline   Reply With Quote
Old 03-21-2015, 10:20 PM   #684
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Same fuelab FPR i was using with the stock pump.
Yeah, it should have a check valve. It looks like a schrader valve. I saw it when i was installing it.
Erat is offline   Reply With Quote
Old 03-21-2015, 11:05 PM   #685
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Damn. Two steps forward one step back with this car...
At least now there are no leaks.

I found these rusty things when i put the FP in.


So they'll be staying off for a while. I wish someone had this replacement part. Probably going to be pulling the pump back out. I'm not positive i NEED a working check valve, but it would be nice for it to work properly.


Also, i remember a while back about vlad not having a working tach. Maybe i talked about this last summer in here... I can't remember anything, i'm high from the gas fumes.
Attached Thumbnails
Slowest turbo Miata ever-image03212015213218.jpg   Slowest turbo Miata ever-image03212015203751.jpg  
Erat is offline   Reply With Quote
Old 03-21-2015, 11:07 PM   #686
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: woosta, ma
Posts: 8,684
Total Cats: 93
Default

My car hasnt retained fuel pressure since I put that shitty aem fpr in the car. Its not a big deal I just turn the key to let it prime a second before starting.
Leafy is offline   Reply With Quote
Old 03-22-2015, 02:22 PM   #687
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Well, the runs and drives great. Need to do a little fender work, but at my ride height it's not rubbing.

I am however rubbing on the LCAs and springs. This is a bit of a disappointment.
Not even full lock.



I'm also hearing a clunk on i think the front right side when braking. I vaguely remember this sound before i put it away for winter.
Attached Thumbnails
Slowest turbo Miata ever-image03222015130724.jpg   Slowest turbo Miata ever-image03222015130738.jpg  
Erat is offline   Reply With Quote
Old 04-14-2015, 07:23 PM   #688
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

I've had the car out a few times this year so far. Tuning the **** out of it. This is starting to be my best tune thus far. I've been tuning MS for years now and each summer i learn more and my car runs better. Maybe MS3 is helping that this year.
Ran it about 75 miles today drove it to work. Spinning to 8500rpm. Feels like she runs out of power just south of 8k though. 10psi, as many washers as i can get behind the wastegate. The bigger TB, fuel system, and Fab9 COPs really seem to be helping. In the last 100 miles i've sucked down a half tank of fuel.

A possible switch to e85 may happen soon too. I'm just being a scared little girl about it.

Still trying to get my tach to work with the COPs.

Oh and the car idles at like 1100rpm. Which isn't much a big deal. I think it's the 60psi base fuel pressure.
Erat is offline   Reply With Quote
Old 04-26-2015, 05:57 PM   #689
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

So i continued on with the beating on this car today.
Found my first failure. I was pretty far from home when it happened so i was kinda worried.

One of the fittings to the fuel rail itself has an o-ring gasket. The o-ring seems to have failed, it sprays fuel everywhere. I actually have "replacement" or other o-rings for these same fittings (they're blue instead of brown). They seem to be the same thickness which has me wondering if i even want to use them. I'll probably try to track down something thicker and more resistant to fuels, Buna-N or something.

I was so pissed about the leak that i boarded the car. It will come out again when all home improvement projects are finished.
Erat is offline   Reply With Quote
Old 04-26-2015, 06:17 PM   #690
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 8,895
Total Cats: 774
Default

Ouch. Fuel leaks scare the hell out of me. Where did the failed o-ring come from?
EO2K is offline   Reply With Quote
Old 04-26-2015, 06:26 PM   #691
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Flyin Miata.

The o-ring looks too thin and weak. When you tighten down the fitting it deforms and squishes out.
It came (or at least i think it did) with some other blue o-rings but they look exactly the same as the brown ones.



It came with the 90s, i'm using the straights.
Attached Thumbnails
Slowest turbo Miata ever-dsc06130.jpg  
Erat is offline   Reply With Quote
Old 04-26-2015, 07:37 PM   #692
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Also, i feel like the car has LESS traction with the R1Rs than the Z1s, even though the R1rs are 30mm wider. Only at 15psi, the car hammers off the fuel cut in 1st because the wheels are just spinning. I don't remember it being as bad before these tires.
Erat is offline   Reply With Quote
Old 04-26-2015, 11:08 PM   #693
Junior Member
 
Sirnixalot's Avatar
 
Join Date: Aug 2005
Location: Cayman Islands
Posts: 410
Total Cats: 13
Default

how many miles do you have on them?

I used to work for the local Toyo dealer, the mold release compound takes a few heat cycles to clear out.

What tire pressures are you running them at?
Sirnixalot is offline   Reply With Quote
Old 04-27-2015, 08:31 AM   #694
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Oh I don't know, 200 miles maybe. Pressure is 30-32psi.
Erat is offline   Reply With Quote
Old 04-27-2015, 09:58 AM   #695
Elite Member
iTrader: (3)
 
Join Date: Aug 2011
Posts: 7,237
Total Cats: 554
Default

Quote:
Originally Posted by Erat View Post
Also, i feel like the car has LESS traction with the R1Rs than the Z1s, even though the R1rs are 30mm wider. Only at 15psi, the car hammers off the fuel cut in 1st because the wheels are just spinning. I don't remember it being as bad before these tires.

You don't have the magic compound R1Rs.
concealer404 is offline   Reply With Quote
Old 04-27-2015, 12:13 PM   #696
Junior Member
 
Sirnixalot's Avatar
 
Join Date: Aug 2005
Location: Cayman Islands
Posts: 410
Total Cats: 13
Default

Quote:
Originally Posted by Erat View Post
Oh I don't know, 200 miles maybe. Pressure is 30-32psi.
you should be good to go as far as the mold release agent is concerned
Sirnixalot is offline   Reply With Quote
Old 04-27-2015, 01:13 PM   #697
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: woosta, ma
Posts: 8,684
Total Cats: 93
Default

Quote:
Originally Posted by concealer404 View Post
You don't have the magic compound R1Rs.
That only matters as far as shaving them down to nothing. They all have the same compound on the outside.
Leafy is offline   Reply With Quote
Old 04-27-2015, 01:32 PM   #698
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

Oh, so i'll get to traction eventually.
Erat is offline   Reply With Quote
Old 04-27-2015, 02:55 PM   #699
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 8,895
Total Cats: 774
Default

Right before they cord
EO2K is offline   Reply With Quote
Old 04-27-2015, 05:54 PM   #700
Elite Member
Thread Starter
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 3,924
Total Cats: 224
Default

They'll never get to that point if i can't get the car to work right without it having some type of catastrophic failure.
Erat is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Turbo 1995 Miata Low mileage Clean Tekel Cars for sale/trade 29 02-05-2016 05:16 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM
2009 Subaru WRX Hatchback - Pearl White - 83k miles - $16999 Braineack Cars for sale/trade 3 09-04-2015 03:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:42 AM.