Where's The Boost? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

DIY Turbo Discussion greddy on a 1.8? homebrew kit?

LinkBack Thread Tools
Old 04-27-2015, 09:27 PM   #1
Thread Starter
Join Date: Oct 2014
Posts: 5
Total Cats: 0
Default Where's The Boost?

As my title suggests, I'm having some issues with my turbo as of late. I have a garrett GT2560 turbo. Predating this issue, I took apart my turbo and used exhaust sealant between the exhaust manifold and the block with a new gasket, between the mani and the turbo flange, and between my turbo and the downpipe with a new gasket. Previous to this I had to trim my turbo to intercooler hose some at the top because of a tear under the metal band clamp holding it to the turbo.

Symptom: boost builds to only 4 psi in 1st gear, and 3rd gear in all other gears after that.

Things I've looked at so far:

- Checked wastegate actuator. Turbo spins with it closed, and doesn't when I force it open.
- Checked performance without air filter, worked the same with the filter.
- Removed vacuum line to wastegate actuator to see if I could build more pressure at all, still no more boost than before.
- Capped off exhaust with my hand, decent pressure built up, and no noticeable leaks caused.
- Looked at all exhaust couplings for soot, found nothing.
- Listened for boost leaks, everything sounds good.
- I've checked for play in my throttle cable and it looks fine.
- Checked turbo turbine for play or hard turning but it's pretty solid, and spins just fine. Only issue is a small blemish on one blade that has been since long ago.

I have two things I've thought of so far:
- Maybe there's an obstruction in my exhaust around the cat, I would think not as the engine runs fine as it sits but worth a look.
- After trimming the intercooler inlet hose, there is a decent kink in the elbow just after the turbo outlet. I could try to trim more or to fit a different hose that fits better.

Does this sound familiar to anyone? Is there anything I'm forgetting? I feel like the kink in the hose SOUNDS like the issue but there was always a little kink. I think things are a little more drastic than before but it doesn't look completely closed off or anything. Rather frustrated as I was easily building up 8psi all day long, but with exhaust leaks. Car sounds great now but no more power...

Last edited by dansnyderECE2010; 04-27-2015 at 09:38 PM.
dansnyderECE2010 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 06:13 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 12:15 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM

exhaust, leak, miata, turbo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:18 PM.