car running like crap after lc-1 ....... help!!!!! - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

ECUs and Tuning Discuss Engine Management, Tuning, & Programming

LinkBack Thread Tools Search this Thread
Old 04-10-2012, 09:50 PM   #1
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 51
Total Cats: 0
Default car running like crap after lc-1 ....... help!!!!!

Hi I just intalled a lc-1, but my stock o2 was dead so I put the lc-1 in stock bung and am running the narrow band emulator to my stock ecunow my car has spurts where it has serious lag until 4500 rpm(vvt area) and rough idle im thinking maybe I need to alter the programming of the narrowband output anyone had any experience with this problem maybe someone can tell me optimal a/f ratio for a naturally aspirated 1.8 thanks.
droptopgokart is offline   Reply With Quote
Old 04-10-2012, 10:34 PM   #2
Elite Member
iTrader: (2)
Mobius's Avatar
Join Date: May 2008
Location: Portland, Oregon
Posts: 2,768
Total Cats: 203

You need a new stock O2. The LC-1 sensor won't like the heat where you've put it.

LC-1 Manual here.

Which color wire from the LC-1 did you connect to your engine harness? Which color wire in the harness did you connect it to?

Did you calibrate the LC-1? Do you have a wideband gauge installed reading off of the LC-1, and is it working?

Edit: also, note that if you expect many responses in this thread past this one, you should really work on cleaning up your posts. My 2nd grader (seriously) can write with better grammar than you are using.
Mobius is offline   Reply With Quote
Old 04-10-2012, 11:34 PM   #3
Tour de Franzia
iTrader: (6)
hustler's Avatar
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 28,930
Total Cats: 326

I was going to reply but I can't read endless run-on sentences like that.
hustler is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 55 09-09-2016 12:52 AM
Rotrex cooling issue gsyk59 Engine Performance 49 11-22-2015 04:11 AM
Looking for some EMS4 help E=MC^2 DIY Turbo Discussion 29 10-20-2015 12:03 AM
Compression test results Colipto General Miata Chat 3 09-11-2015 01:44 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 08:30 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:47 PM.