clutch squeaks after a long drive - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 04-05-2010, 01:30 AM   #1
Senior Member
Thread Starter
iTrader: (6)
Join Date: Sep 2007
Posts: 1,029
Total Cats: 24
Default clutch squeaks after a long drive

This issue has gotten worse over the past year. After a drive of a hour or two, when pushing the clutch in or letting it out, there's a noticeable squeak and some resistance in the pedal. I checked to make sure that there's plenty of grease where the slave cylinder is, this seems to be more of an issue under the dash. I've squeezed some lithium grease in some spots but it doesn't seem to make a difference.

albumleaf is offline   Reply With Quote
Old 04-05-2010, 01:37 AM   #2
Elite Member
iTrader: (13)
cjernigan's Avatar
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 5

The rod between the pedal and the master cylinder might be causing the squeak. The master cylinder itself might be squeaking as well. I can't remember if you can get to the backside of the rod under the dash or not. If so some spray lube might solve it.
cjernigan is offline   Reply With Quote
Old 04-05-2010, 08:15 AM   #3
Elite Member
iTrader: (12)
Join Date: Sep 2007
Location: Portland, Oregon.
Posts: 6,841
Total Cats: 63

Does it sound like a big *** cricket? lol

I had this issue and it turned out to be the rod that pushes on the clutch fork. Pull the boot back and lubricate the slave cylinder.
Doppelgänger is offline   Reply With Quote
Old 04-05-2010, 10:09 AM   #4
Elite Member
iTrader: (2)
Faeflora's Avatar
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,763
Total Cats: 116

Ditto on the clutch fork rod. My pedal also squeaks (squweaks?) at the under-the-dash linkages.
Faeflora is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
Noob to Miataturbo from MA JxPhan Meet and Greet 3 10-02-2015 02:17 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 01:42 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:06 PM.