Question about ignition - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 06-18-2015, 06:21 PM   #1
Elite Member
Thread Starter
iTrader: (19)
Join Date: Jun 2007
Location: Rochester, NY
Posts: 5,141
Total Cats: 301
Default Question about ignition

I have noticed recently that when I go to start the car, sometimes all I get it a click. Releasing the key and trying again (sometimes several times) results in it eventually starting. Reading ( tells me this is a somewhat common problem on these cars after 20+ years. I plan on pulling the switch off the column and cleaning it this weekend. That's not the issue.

The real issue is that the car sometimes "stumbles" when I'm cruising at speed. It feels like a misfire. Now, this is NY, so obviously, the roads suck. My suspension is stiff, and it means the car takes these bumps hard. I haven't been able to positively correlate bump/misfire, but I suspect it's the switch cutting out or arcing.

Is this a reasonable assumption, or do I need to go looking for other causes? This kind of thing caused me to nearly get plowed by a semi in my Jeep (which stalled completely in rush hour traffic at 65mph), and it makes me really nervous.

Any suggestions?
rleete is offline   Reply With Quote
Old 06-18-2015, 10:46 PM   #2
Senior Member
iTrader: (2)
dc2696's Avatar
Join Date: May 2005
Location: Edmonton Ab, Canada
Posts: 1,141
Total Cats: 8

My old setup had an issue with coil pack wires getting jolted after driving with SM suspension on **** roads for a year. Or maybe it was CAS wires... One of those shitty connections.
dc2696 is offline   Reply With Quote
Old 06-23-2015, 08:34 AM   #3
Senior Member
iTrader: (8)
Join Date: Oct 2006
Location: Lexington SC
Posts: 950
Total Cats: 12

I had a similar start issue on my wife's 97 for a while where you had to bump the key a few times to get the starter to kick in. Didn't do it all the time though. I tried cleaning it, but ended up swapping in a used ignition switch and it worked fine after that. I didn't have random stalling issues with that one though.

I did have random stumbling and stalling issues with my 91 after I swapped in the 1.8. Turned out to be the crappy wiring I used to extend the CAS wiring to move it from intake to exhaust cam when doing the 1.8 swap. Check those wires and connectors.
Rallas is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 07:58 AM
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 9 11-07-2015 11:58 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 02:44 PM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 11:48 AM
NA Seat Sliders and Seat Belt Receivers skipstr Miata parts for sale/trade 2 09-28-2015 10:53 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:14 PM.