TEC 2 Back on the road BUT! - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 03-08-2008, 03:15 PM   #1
Thread Starter
Join Date: Jun 2007
Posts: 30
Total Cats: 0
Default TEC 2 Back on the road BUT!

Got my 1.6 turbo back on the road again but have a little problem and could do with some advice.

The car cuts out on me and the TEC2 is reading an 'intermittent' TPS failure, Ive checked the wires and all seem fine. Did it on me the other day and I just tap the TPS (1.6 auto round type) turned the key and its fine. Then other days no probs?? Any one else had this or has anyone got a spare auto TPS?

Also I'm on the look out for fellow users of the TEC2 anyone?

Lanks is offline   Reply With Quote
Old 03-09-2008, 04:01 AM   #2
Junior Member
Join Date: Jan 2007
Location: EXTREME Southern Illinois
Posts: 281
Total Cats: 0

I used to have a TEC2 on mine. Now it lives in a cardboard box.

I fought with it for a couple years, so I know it pretty well, but memories fade. Check the TPS with a volt-meter and see if it's operating smoothly. If it's like mine ('99) it should go from ~.5v to ~4.5v. The smoothness is more important than the actual voltage readings. If the TPS checks out, then check those silly screw-connects on the TEC, I frequently had trouble with those.
DammitBeavis is offline   Reply With Quote
Old 03-10-2008, 12:29 PM   #3
Thread Starter
Join Date: Jun 2007
Posts: 30
Total Cats: 0

Cheers will do.

What are you doing with your old TEC2? Think of selling it?
Lanks is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 03:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 12:15 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:48 PM.