Trailer wiring - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 07-25-2015, 06:45 PM   #1
Junior Member
Thread Starter
Join Date: Sep 2014
Location: Portland (left coast)
Posts: 191
Total Cats: 2
Default Trailer wiring

I feel like an *** b/c I can't figure this out so I've put my flame suit on and I'm bustin' out a post.

2004 MSM
Curt wiring harness

Harbor Freight Trailer: Heavy Duty Utility Trailer - 870 Lb. Capacity

The parking lights work, brake and turn on both sides do not. Added dedicated grounds to the rear lights as suggested by some to solve the issue. Made sure the grounds are not going over paint/powder coating.

Tried following the FM hitch wiring set-up:

And this wiring set-up: Mostly MIATA: Trailer Hitch Installation

with the same results; power to the parking lights and that is it.

Any ideas what I need to be doing different? Do I need a different wiring adaptor to deal with the independent brake and turn on the Miata vs. them being combined on the trailer?

tazswing is offline   Reply With Quote
Old 07-25-2015, 10:51 PM   #2
Senior Member
iTrader: (2)
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 657
Total Cats: 46

They should be working if you followed the quoted instructions, i would first see if When you turn the position lights on one or both bulb filaments come on, only one should come on.
Then use a test loght or bolt meter to see if you are getting 12v at the correct converter box wires for turn and brake lights, it seems unlikley that you would have 3 bad tap connections.
If you are getting voltage on each turn signal and brake light coming into the converter box the box is probably bad, if you are not the problem would be bad connections (or a blown fuse if your car lights are nor working either).
HHammerly is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 01:11 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 4 09-28-2015 10:10 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 07:39 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 05:33 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:10 AM.