Vacuum leak and climbing boost problem - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 06-07-2015, 03:03 PM   #1
Thread Starter
Join Date: Oct 2010
Posts: 25
Total Cats: 0
Default Vacuum leak and climbing boost problem

yeaterday at an event I ran into a problem. I had a loss of power so I pulled into the pits. I noticed I popped a hose. I thought easy fix, took it for a test drive and I only had 11 for vacuum. Gave it some gas and it climbed to 20 psi instead of 14. I also heared turbo flutter. So I figure the over boost probably popped the hose and the bov is probably not opening to cause the flutter. I bypassed the manual boost controller and ran stock wastegate pressure, Around 10 psi. It stayed at 10 and had good a/f after adjusting. I finished the event on this setup but I still have 11 vacuum. Cannot find a leak. I tried spraying. Tightening all hoses ect. Any advise on what's going on for all those problems to occur at once? Thanks
karcher is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 12:15 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 10:59 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:44 PM.