IAT sensor failing? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 08-12-2008, 12:10 AM   #1
Junior Member
Thread Starter
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 220
Total Cats: 4
Default IAT sensor failing?

im wondering what temps people are getting for a non intercooled setup during these summer months. I seem to be having an issue where the thermocouple in the sensor will break after the temperature spikes.

will putting some silicone or something to hold the wires would help in making the sensor itself last longer or would it cause heat soak from the material being so close to the thermocouple?

this is just a bandaid for now, i have a complete intercooler setup, but now i need to remake the tubes on the turbo to intercooler side again, since this new car has AC and power steering. im just sick of a sensor seeming to go bad every 4th day when im constantly watching the intake temps
Dlaitini is offline   Reply With Quote
Old 08-12-2008, 07:39 AM   #2
Elite Member
iTrader: (21)
paul's Avatar
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2

What is the sensor mounted in? Sounds like vibration is too high. If you pull the ceramic tip off and are careful you can silicone the leads to help. Just keep it off the thermistor. I've never had a problem with mine and they've both seen temps in the 150's(before I intercooled)

Last edited by paul; 08-13-2008 at 07:36 AM.
paul is offline   Reply With Quote
Old 08-12-2008, 10:44 AM   #3
Junior Member
Thread Starter
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 220
Total Cats: 4

I have the BEGI-s kit, and its in the tube right before the throttle body.
Dlaitini is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 11:04 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 04:46 PM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 10:44 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:19 AM.