Launch control setup issues - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 07-23-2015, 04:36 PM   #1
Thread Starter
Join Date: Jul 2015
Posts: 2
Total Cats: 0
Default Launch control setup issues

So I have a mspnp 2 and have setup launch control as per the diyautotune instructions. I removed the clutch switch jumper, wired into launch control input to my separate external switch, and wired the other end of the switch to a chassis ground. I turned launch control on in tunerstudio and with all of the original parameters in settings, nothing is working thus far. I feel like I am missing something small here.
Riley Zacharias is offline   Reply With Quote
Old 07-23-2015, 04:44 PM   #2
Elite Member
iTrader: (14)
patsmx5's Avatar
Join Date: Aug 2007
Location: Houston, TX
Posts: 7,811
Total Cats: 119

Sounds like you wired it to the clutch switch that's used to prevent starting the engine without the clutch fully depressed? If so, wrong switch. There is another clutch switch that is pressed ONLY when the clutch pedal is 100% out. As soon as you begin to push the clutch pedal in, this clutch switch trips. This is the one you wire to MS for launch control. You can keep the jumper in the other switch so you can start without pressing the clutch.
patsmx5 is offline   Reply With Quote
Old 07-23-2015, 05:07 PM   #3
Thread Starter
Join Date: Jul 2015
Posts: 2
Total Cats: 0

Sorry to clarify I mean an external on/off switch, not one of the two clutch switches
Riley Zacharias is offline   Reply With Quote
Old 07-24-2015, 09:31 AM   #4
Junior Member
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 220
Total Cats: 4

did you disconnect the neutral switch in the transmission? it is wired in such as way that if you are in gear it keeps the ECU from activating launch control.

Just have to unplug it on the passenger side of the trans
Dlaitini is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 07:18 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 02:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:03 AM.