Megasquirt Cold Start Issues - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 06-01-2015, 03:01 PM   #1
Thread Starter
Join Date: Oct 2014
Posts: 12
Total Cats: 0
Default Megasquirt Cold Start Issues

Hello all

i have a mx5 1.8 1997 mk1 with a sturovo manifold td04, with 550cc bosch ev14 and reverent ms2.

i have the problem that when i start the car from cold in the mornings the engine takes approximately 5 seconds to catch, just before it catches it almost locks the engine.

if i try to start again it usually fires.

the car starts ok from warm and hot.

i have searched other topics and could only find similar issues with no outcome.

Thanks in advance
naw43 is offline   Reply With Quote
Old 06-01-2015, 07:37 PM   #2
Junior Member
Join Date: Jan 2014
Location: Boca Raton,FL
Posts: 348
Total Cats: 3

I had similar issue, browse thru my thread and see if it gives you any ideas.

Struggle to crank
Mech5700 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 11:04 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 09:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 02:44 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:24 AM.