no Tach/RPM - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 03-18-2010, 05:53 PM   #1
Senior Member
Thread Starter
iTrader: (1)
Join Date: Jun 2006
Location: Outside of the Loop-ATL
Posts: 754
Total Cats: 0
Default no Tach/RPM

Ok so I have a problem, I am not getting any RPM signal out of my MS. I have bugged Matt and Ben a few too many times so before I go knock on Ben's door again, I'd see if some of you guys could help.

Short version:
Tested against different Stims, but can't get any RPM signal from the MS. The tach signal is entering and leaving the U3 chip but is getting lost before making it to anywhere else. No tach in MS and no spark when hooked to a car.

Specs of the MS.

MS1 v3.0
Input/Output mod brain has in the MS build instructions.

Longer version:
U3 diagram:

Had Ben look at the MS a while back, and he fixed a burnt trace from U3[pin 1] to R12. Matt hooked up my board to the nice oscilloscope at DIYAutotune and noticed U3 is getting signal in and signal out. I tried jumping u3 [pin2] to the xg, but no change

Using that diagram. I been able to follow Pin1 and pin2 input and output. Pin 3 isn't used in this chip(looked up internal chip path). I think Pin 4 goes to R13 and some OptoOut(can't figure out what that is) pin 5 doesn't seem to lead anyway, or at least they aren't showing it. and pin 6 is just a ground.

So I need to try and trace where the signal goes after it leaves U3 but that diagram doesn't help much.

Please this would be a great big help.
wildfire0310 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Reverant MS unit - no tach / rpm cpolly69 MEGAsquirt 21 05-25-2012 05:04 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:57 AM.