Lean above 6K or misfire? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market TrackSpeed

LinkBack Thread Tools
Old 06-29-2008, 12:45 AM   #1
Thread Starter
Join Date: Mar 2008
Location: Nashville, TN
Posts: 38
Total Cats: 0
Default Lean above 6K or misfire?

Hi everyone.

I've had the voodoo II on my 97M for about 3 weeks now. I'm just really getting to enjoy it after I installed the ACT HD clutch last week. What I'm noticing is starting in second gear, as I rev through the RPM range, I feel a hesitation after 6K. I'm boosting around 7psi at 8 deg static timing (no audible knock). According to the AEM wideband, from about 3000-4500 i'm around 11.6:1 then 12.2:1 up to 6K. All of a sudden it's like I hit a soft limit around 6500 and A/F goes immediately to 14:1 or 16:1. I don't notice the tach bounce.
FWIW on the voodoo box, both fuel pots are full up. When I installed the turbo, I put in new plugs and NGK blue wires. The plugs are NGK BKR6e11 originally gapped to .034 per FM's instructions. Yesterday, I gapped them down to .025 with no change. I also have the stock fuel pump, which shows a max FP of 80ish psi when deadheading the return line. Could the injectors just "give out" after 6K? They're just the stock 1.8's. Just can't tell if I'm lean which is causing the hesitation, or it's a high rpm misfire which I THINK the wideband would show as lean as well.


Costa is offline   Reply With Quote
Old 06-29-2008, 08:06 AM   #2
Elite Member
iTrader: (21)
paul's Avatar
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2

Misfire would show as rich because you would have unburnt fuel.

Without a rising rate FPR isn't that asking a lot of the stock injectors?

What happens if you bring the RPMs up to 7k without going into boost?

I think .025 gap is too small. I'd set em back to .034
paul is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Misfire in cyl #3, possible causes? SJP0tato Engine Performance 10 06-02-2013 03:28 PM
odd High boost misfire issue. spaztikcamel General Miata Chat 5 06-08-2012 01:07 AM
Misfire under load. cat10 MEGAsquirt 12 08-04-2010 08:32 PM
Hot restart hi-vacuum misfire JasonC SBB ECUs and Tuning 2 04-18-2010 01:54 PM
Dwell setting for my MSM? evank MEGAsquirt 8 04-03-2009 06:07 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:53 PM.