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Things you’ll need to have to install DIYPNP:

Serial to USB cable
6’ of vacuum line
Vacuum tee

Timing light

Laptop

WBo2

Tools you may need:
10mm socket

Pliers

Razor/scissors

What’s in the box:

Assembled and configured diyautotune.com DIYPNP unit

DB15 pigtail for inputs/outputs (page 5)
GM AIT sensor kit

EBC Boost Solenoid (optional)

Unused parts during assembly (not pictured)
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Wiring Your Megasquirt (MS):
1.6L:

Your ECU is located under the passenger foot rest. Remove the side sill with a Phillips head
screw driver and pull the carpet back, the cover can be lifted off after removing (5) 20mm nuts.

1.8L:

Your ECU is located behind the passenger seat. Remove the side sill with a Phillips head screw
driver and pull the carpet back, off the ECU. The ECU can be lifted off after removing 3 10mm
nuts.

Remove the ECU, plug the OEM connectors into your new harness and attach the DB37
connector to your MS (be certain to screw in the connector).

99-05
Your ECU is under the dash next to the steering column. The singular Motorsports mounting
bracket is recommended for NB installations.

See: http://www.good-win-racing.com/Mazda-Performance-Part/61-1587.html
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Air Intake Temp (AIT) Sensor / Fuel Pump / EBC solenoid

The MS harness is wired so hooking up the AIT sensor, activating the fuel pump (1.6L only), and

EBC is very easy and without the need to splice, crimp, or solder.

With the provided wire in the AIT bundle, wire your new GM AIT sensor by pushing the spade

connectors directly into the AFM/MAF harness. Polarity doesn’t matter.

1.6L owners will have a provided length of wire they can use to jump the two pins for the fuel
pump. This connects to the MS to the fuel pump relay so it can control the fuel pump properly.

1.6L owners will have to connect the solenoid to a switched power supply inside the engine bay.

The blue power connector is the ideal choice. See below.

1.6L AFM Connector

1 L
2P 20 2D 2K 2D GND F/P

Fuel Pump Jumper

Switched 12v - white/red
(Blue Power Connector ecommended)

Boost Solenoid
{polarity does not matter)

GM AIT Sensor
{polarity does not matter)
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1.8L NA MAF Connector 1.8L NB & NB2 MAF Connector

4A 4X 4AF

Boost Solenoid 9
(polarity does not matter)

GM AIT Sensor Boost Solenoid
(polarity does not matter) y
(polarity does not matter)

99-05: Your AIT sensor is located behind the MAF on the intake pipe, unplug it and use that
connector in the same fashion as the above.

Installation note: Fold the wires over the side of the connector and then wrap it a few times with
electrical tape to prevent them from pulling out; tuck away under the brake booster.
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WBO2:

DB15 Connector
Your DB15 connector is prewired to power your WBo2
Controller and accept your WBo02 input.

Wire: o ;ﬁﬁbf'&*

Power to pin 1.

Ground to pin 2.

WB Output to pin 4. (Yellow wire on LC1/2/MTX-L) 1 OO000O0 |8
N_PRO00O0 15

Installation Note: If your DB15 has additional wires on it R G§
please refer to the pinout on the right. &

Powering a Boost Solenoid (1.6L only):

Connect one wire of the solenoid to the little blue +12v connector near the driver headlight (it has
a cap on it, when you pull it off it’s just a little spade), or any or other switched/fused +12volt
power source in the engine bay (white/red).

-

The Blue Power Connector is the easiest to use as you’ll most likely be mounting it there anyway.
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Plumbing a Boost Solenoid:

The boost goes into the lower port
on the side with two ports. The
exhaust to the wastegate is on the
side with only one port. This
should be labeled.

®
The best boost source would be =P To Wastegate

between the intercooler and throttle  ggost Source s ®

body. Itis not recommended to

source boost from the intake

manifold because the vacuum can

potential damage the wastegate or cause issues. Sourcing boost from the turbo is the easiest.

MAP SENSOR:

Run a vacuum line from your intake manifold to the MAP sensor inside MS. The ideal spot is
teeing off the FPR on the back of the manifold. If you use a different port the map signal tends to
spike when it shouldn’t due to turbulence.

s

2N TN

e
-

There is a grommet on the firewall you can pass the vacuum line through. Pop it out, drill a hole
to fit the vacuum line through, and start feeding it in. You'll need to reach up behind the insulation
and glove box to find it.
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TPS:

***1.6L users YOU MUST DISCONNECT your stock TPS connector***
Failure to disconnect the TPS will result in the MS unable to connect to laptop and start the car.

The stock TPS sensor is just an On/Off switch and the MS cannot do anything with the signal.
Your harness is prewired to work in conjunction with a vTPS (like the Wells TPS201 mod as
outlined on miatatubo.net) or automatic throttle body. Wiring it this way gives you an easy
upgrade opportunity: allowing you to use TPSdot enrichments instead of MAPdot.

See: http://www.miataturbo.net/forum/t12239/#post157397

To install a vTPS simply connect to the stock TPS harness as follows:

Function OE Wire Color :

TPS Signal Lt. Green / White
Ground Black / Green
5v Red

Installation Note: You will also need to remove the resistor jumping 4L and 4D within the
DIYPNP unit when upgrading. Failure to remove this resistor will prevent the vTPS from reading.

How to wire a 1.8L throttle body to the 1.6L harness:
OE 1.8L TPS Pigtail OE TPS Harness

5IG GND 5v

J

NOTE: IF YOU DON'T HAVE A TACH SIGNAL ON YOUR DASH (90-95):

Use a spare 1K resistor from your package and
jump IG- and B+ in your diagnostics box.

Shaped it into a wide “U” and trim the legs down so
it fits inside the cover. Make sure it doesn’t touch
any other pins -- B+ connects directly to the battery.
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DONE WITH THE HARDWARE, ONTO THE SOFTWARE.

Once you've finished the external DIYPNP wiring and have connected the factory harness to the
MS harness, connect your serial to usb cable to your MS, and power up the unit (key ON). You
should hear the fuel pump activate.

Make sure the usb>serial drivers install properly and your computer assigns the cable a com port.

If you cannot get past this stage, contact me before continuing.
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Software Setup:

Download the latest release of Tuner Studio software.

http://www.tunerstudio.com/index.php/downloads

NOTE: It is highly recommended that you pay to register the product. This gains you access to
VE Analyze LIVE which can autotune your fuel map.

To start, go to the file menu, and select New Project.

Under the pull up menu in Projects, you will be given a few choices related to the project. Since
you want to set up for your car, the first thing you want to do is SELECT NEW PROJECT.

This screen should open up:

¢l Create Mew Project >
Hew Tuner5tudio Project

Project Configuration
Project Name

NAME YOUR PROJECT HERE|

Project Directory
umentsiTunerstudioProjects\NAME YOUR PROJECT HERE| Browse

Firmware

Detect

[ | Other | Browse
[ | Show Advanced | Offline Setup

Project Description

Cancel Hext =

Name the project something that you can easily Identify, and make it specific. For example, “My
DIYPNP Project” you can name it whatever you like, it doesn’t really matter.

Make sure under “Project Directory,” to save it to the Tuner Studio Projects Folder, which should

default in your My Documents folder. Otherwise on some Vista and 7 machines, you may have
issues saving files.
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Next, you need to select the firmware you will be using. With the MS unit installed and powered

with key ON, click DETECT.

The software should find your MS3x unit, and determine the firmware. Hit Accept. You may be
prompted to download the firmware file locally, so you’ll need an internet connection if prompted.

On the next page, choose your Configuration settings.
Choose your WB choice, Temperature Display settings,
and match the rest like the right:

On the next page, the software will test the connection to
your MS3X, so make sure the MS remains ON:

2k Create Mew Project |
New TunerStudio Project
Communication Settings
Configuration: |compuw22c1 | - |
Driver: |RS232 Serial (Default) |v|
Port: |{:D|.l'|5 |v|
Baud Rate: |1152UU |v|
Successfulll! Test Port
‘ < Back | ‘ Hext = ‘

If you don’t have a “Successfull!l” message like above,
please contact me.

Click next and select the default dashboard, you must
register the program (which you should) in order to
change the display.

When you hit Okay, the software should connect to the
MS3x and you should see data on the gauges on the
digital dashboard.

¢k Create New Project *

New TunerStudio Project

Configuration Settings
Oxygen Sensor | Display

\WideBand - AFR (Defautt) -

Temperature Display
|Fanrenneitmefau|t} |v|

CAN_COMMANDS
|Deactivated (Defautt) v

EXPANDED_CLT_TEMP

|Deactivated (Defautt) v
MPH

|Acti1.rated (Default) | - |
METRES

|Activated (Defaut) v

INTERNAL_LOG_FIELDS

| Deactivated (Default) | = |
PW_4x
|Dea ctivated (Default) | = |

CYL 12 16_SUPPORT
|Deactivated (Defautt) v

PORT_STATUS
| Deactivated (Default) | - |

| < Back || Next = |
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Configuring your Sensors
Under Tools > Calibrate TPS

e  With your foot OFF the throttle, click 'GET CURRENT' for the Closed Throttle ADC Count
e Floor it and hold it there. Click 'GET CURRENT! for the Full Throttle ADC Count
e Click Close

Calibrate your CLT Sensor and IAT Sensor.

e Again from TunerStudio, click 'Tools > Calibrate Thermistor Tables'. Make sure 'Coolant
Temperature Sensor' is selected at the top.

For the 90-97 CLT, use “RX7_CLT (S4 & S5)” from the common sensor values.

For the 99-05 CLT, use the following table with a bias resistor setting of 2490 ohms:

Temperature F/C  Resistance In Ohms

14/-10 9000
68/ 20 2500
176 /80 320

e Enter these values, and click 'Write to Controller.
Select 'Intake Temperature Sensor' at the top in the drop down box.

e For the GM IAT sensor, select GM from the “common sensor values” and click "Write to
Controller. Now click Close to Exit.

Finally, you should calibrate your O2 Sensor to the ECU.
To do this, click 'Tools > Calibrate AFR Table'.

e Choose your O2 Sensor from the list. Choose Narrowband for the stock O2 Sensor. Or
select your wideband and the proper configuration of said wideband from the drop-down
list. If you are using an LC-1 or MTX-L, try using .23v — 7:35 and 5v — 22.39:1.

e Click 'Write to Controller'. Once finished writing, click 'Close'.

Now click 'Tools > Un/Lock Calibrations' and change the sensors from unlocked to locked, then
click burn and close.
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Configuring your tune:

Once you start the car, the first thing you have to do it match the ignition
timing! MS has no idea what your timing is so driving on your new ECU
without doing this is potential for serious failure.

Start and idle the car and allow it to warm-up and stabilize.

Open up Basic Setup > More Ignition Options.

To adjust the timing you adjust the trigger angle, that’s it. No more rotating the CAS, this is same

concept.

Change the “Fixed Advance” from ‘Use table’ to ‘Fixed Timing’, then make sure ‘Timing for Fixed
Advanced’ is set to “10.0”. By doing this, you're telling your Megasquirt to hold the ignition timing
at 10° no matter what. This is essentially what you are doing when you would jump GND and
TEN in the past. Since MS has control of your timing now, this is how you can lock the timing.

B. More Ignition Options

X

B. More Ignition Options

More Ignition Options

More Ignition Options

Fixed Advance [Use Table

Llse Table

Lse Prediction

Titming for Fixed Advanceld

- Cranking Dwellfrms) 5.0
Cranking Advanceidegrees) 15.0

- Dvwvell type | Standard Dwell

Maximum Dwell Duration{ms) |257
Acceleration Compensationims) I'li
Maximum Spark Duration{ms) |EIT7
Dl tirme (ms) b7
" Dwvell dutyi%) o

MOTE: Spark hardware latency shauld OMNLY he used if
ywou notice spark retard with increasing rpms.

' Spark Hardware Latency{usec) 0 E
f middle LED indicator | Of

oo

NG

L

SN Clolclolclo

“Owerdwell protection | Off v|

Underdvwell pratection | Off v|

Ly

Fixed Advance | Fixed timing

Ly

Use Prediction | Mo Prediction

“Titming for Fixed Advanceidedrees) Ilili
- Cranking Dwellims) a.0
- Cranking Advance(degrees) 145.0

- Dvwwvell type | Standard Crwell

Maximum Dwell Durationdms) |257
Acceleration Compensation(ms) |17
Maximum Spark Duration{ms) ltli'i
Dl time(ms) b7
" Dwvall duty(%) o

MOTE: Spark hardware latency should ORLY be used if
you notice spark retard with increasing rpms.

' Spark Hardware Latency(usec) ] g
fmiddle LED indicator | Off

(afclorclo

i

)

e Clolclolclo

“ Owerdweall pratection | Off v|

Underdwell protection | Off v|

A @ [on [ o]

) @ [ ]am]
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Use your timing light and verify the timing is correct. The timing mark should land on 10°. Ifit's
not a match, change the trigger angle a few points and try again.

Go to Tools > Trigger Wizard

Trigger Wizard g]

0.0

Advance (degrees)

Match above value with timing light reading.

Ignition Offset angle(deg) SFXT]| . +

Press Lip/Down arroves to adjust. Hold Shift to adjust by 5

g | Bum || Close |

Click + or — until your timing mark lines up to 10*. Once your timing light indicates 10° you have
now synced the CAS position and the MS.

Back in “More Ignition Options”

Let's make sure your spark hardware latency is configured. You can see by default it’s set to 0.
You can verify by locking ignition timing 10°, which it should still be and then slowly running the
engine from idle to 6,000 RPM while observing with a timing gun. If the spark tends to retard as
RPM goes up, you need to add latency correction until it stays at 10*. This will prevent your
timing from dropping in higher rpms.

Now, change the “Fixed Angle” back to “Use Map”. If you fail to do this, your
timing will remain at 10° regard of RPM or load; this will overheat your motor fast and run very
sluggish. If you go back out with a timing light you should see you’re probably idling in the 15-18°
range.

That's it! You're now ready to tune this baby up. You changed your timing back to “use map”
right?
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Your spark table, by default, is a good conservative table; so focus on fuel.

Go to basic setting > VE Table 1

E. "VE Table 1"

PRI ERE

oW o — — D .

=

ram

O [ | oo

That’s the fuel map, when idling you can see where it's reading the map at. When you drive you
can see your AFR gauge react to whatever situation your map is in. Adjust as needed. It should
be close...you might have to increase the table by 5-10 point throughout to idle good.

If you highlight cell you can plug numbers in on the top. If you want to increase by 5 points,
highlight the cells you want, hit the plus sign, and then enter in a value.
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% "VE Table 1"

S O — — DT s

®

1400 | 2000 | 2600 | 3100 | 3700 | 4300 | 4800 | 5400 | 5300 | 6200 | 6800

Farm

a @ (oo

Tuning:
Setup your AFR target.
Turn EGO Control on. Step size 1% will allow the ECU to make on the fly adjustments based of

your AFR reading to try to match your AFR targets table. You can change the speed it reacts
(events per step), how much it can change your table numbers (Auth) and other parameters.
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E. EGOD Control

EGO Control

© EGO Sensar Type [Single Wide Band
@ Znd EGO sensar port | M52 ADEISE

|gnition Events per Step 16

* Controller Step Size (%)

C Cantraller Auth +-(%)

Bl

L

 Active Above Coolant(®F) 160.0
* Active Above RPM

 Artive Below TPS(%) 100.0
* Active Below MAP (P &) 120.00
 Active Above MAPKPa) 20.00

WE Controller Settings

£l

 Algarithrm | Simple

" PID Prapartional Gain(%) |1DD
“PID Integralis) IED
" PID Detivative (%) ID

dr 4 r dr

@ [0 ][ omr]

Then go to Basic Settings > AFR table 1 — Setup your AFR targets how you’d like, these are my
defaults.

E. “AFR Table 1"

L] 30 vie

oo O — — D=

-

SEEWEOE

1400 | 2000 | 2600 | 3100 | 3700 | 4900 | 5000 | 3600 | 7200

F [ Eurn H glnse}

These are the AFR targets you're telling the MS you want to hit.
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If you click the VE Analyze Live tab, TunerStudio software can autotune your fuel map based off
your AFR targets while you drive, this will be the quickest way to get your map tuned to your

setup.

Histogram

[H\gh Res Ready

2. TunerStudio MS(Beta) - High Res (MS/Extra format hr_10 =) [o &=
Eile Options Datalogging Communications Tools Help
1)< Basic Settings H &, CrankMarmUp | ‘ B More settings H < @ Spark ” 1 Advancea H <&, Tuning |
Gauge Cluster Diagnostics | VE Analyze Live
Fuel VE Table 1 | VE Table 2 (DT) | Fuel VE Table 3 |
Fuel VE Table 1 Control Panel
- []3DView | Status | Advanced Settings
Off Line Cell Weighting
230 a5 85 85 106 116 120 123 124 125 | 126 | 128 | 129
212 83 83 83 108 17 118 120 119 120 120 123 124
183 a2 a2 a2 104 113 120 123 119 120 120 122 122
m|_156 81 81 91 104 109 118 120 120 123 123 124 125
a|_ 128 a0 a0 a6 95 100 110 112 113 119 121 124 125
P01 67 70 72 70 73 74 75 80 83 83 80 74
o |84 64 67 58 58 61 60 62 66 T T 75 73 Cell Change
p|_T78 63 65 57 56 58 56 59 63 73 73 71 69
a ki) 61 63 52 50 56 52 53 59 69 69 67 65
34 47 52 64 64 62 60
28 a7 a0 62 62 60 58
20 47 48 60 60 58 56
1000 | 1300 | 1900 | 2300 | 2900 | 3400 | 4000 | 4600 | 5200 | 5700 | 6300 | 7000
pm
VeAnalyze Stats
Total Records: Filtered Records: Used Records:
Total Table Cells: Cells Altered: Average Cell Weight:
Average Cell Change: Max Cell Change: Active Filter:

Please visit: http://www.miataturbo.net/forum/t42925/?highlight=tunerstudio for more discussion

on tuning with VE Analyze Live.

To record logs go to Datalogging > Start Logging.

Go out for a cruise once you get the fuel relatively close. And record the session.
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Final note: your over boost protection might kick in if you hit boost lower than the threshold, so
you might need to change that as well. | have it set low just in case.

E. Overboost Protection

Overhoost Protection

-
—

Owerboost protection [Eh:uth |

" Maximum BoostikPa) 2048.0 =

HysteresisikPa)

CCut¥ sparks

']) ﬂ l Burn H Close J

Go to megasquirtpnp.com and read through their articles on tuning and installation for better help.

faNeoNclofcin

il

Msextra.com is a great forum for MS specific questions.

And of course the miataturbo.net megasquirt forum.
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