18psi's Build Thread finally :) - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-27-2009, 09:48 PM   #41
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

HAHAHAHAH, whats up *****
I just like to watch you ------s crash

Last edited by 18psi; 02-28-2009 at 01:52 AM.
18psi is offline   Reply With Quote
Old 02-27-2009, 10:13 PM   #42
Elite Member
iTrader: (13)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,703
Total Cats: 237
Default

Any updates?
Fireindc is offline   Reply With Quote
Old 02-28-2009, 01:52 AM   #43
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

Picking up my adaptronic at the post office tomorrow since they need a signature and I wasnt home today

hopefully tomorrow I'll be up and running
18psi is offline   Reply With Quote
Old 02-28-2009, 03:13 PM   #44
Newb
 
Join Date: Feb 2008
Location: London, England
Posts: 33
Total Cats: 0
Default

i will be watching this thread closely i intend to some thing similar on my NA. looks good keep up the great work.
Mxslide is offline   Reply With Quote
Old 02-28-2009, 04:47 PM   #45
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

ADAPTRONIC RECEIVED!!!!

map sensor not received yet

hopefully I can get everything plugged in and at least running enough to drive it home from my dads shop (1-2 miles) tonight
18psi is offline   Reply With Quote
Old 02-28-2009, 04:54 PM   #46
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Why did they send the computer without the map sensor? I'm guessing Travis doesn't stock any of this stuff?
patsmx5 is offline   Reply With Quote
Old 02-28-2009, 05:18 PM   #47
Elite Member
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Quote:
Originally Posted by patsmx5 View Post
Why did they send the computer without the map sensor? I'm guessing Travis doesn't stock any of this stuff?
Mine was bad, so Vlad OK'ed Travis to send me his as I was further along. His is coming separately.

He isn't stocking anything yet.
Stein is offline   Reply With Quote
Old 03-03-2009, 04:25 PM   #48
Former Vendor
 
Join Date: Oct 2008
Location: Oklahoma City
Posts: 395
Total Cats: 4
Default

Good Lookin Build
Deatschwerks is offline   Reply With Quote
Old 03-04-2009, 06:39 PM   #49
Junior Member
 
Join Date: Jan 2008
Posts: 272
Total Cats: 0
Default

Nice build...can't wait to see it in person..
Sleeper_MX5 is offline   Reply With Quote
Old 03-04-2009, 07:15 PM   #50
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

thanx guys
I am THIIIIIIIIS close to finishing it
18psi is offline   Reply With Quote
Old 03-04-2009, 07:21 PM   #51
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Advice: After driving it and letting it cool down 100%, retorque EVERYTHING. Take it easy at first and make it safe to drive. Tune on wastegate pressure and run that for a few days till you get it ironed out and learn how to tune with your fancysmancy ecu.
patsmx5 is offline   Reply With Quote
Old 03-04-2009, 07:27 PM   #52
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

oh definitely. I did not hook up the mbc yet, and dont plan to for quite some time. I think the stock wg is set to 10psi, but is adjustible so I'll loosen it a bunch to start off with. 460's should be back from deatschwerks pretty soon, after I get everything running good I'll drop em in and crank it up some. I did order a slim fan off ebay that supposedly flows 1750cfm so that will be a project for this weekend if I get em. I have a leak at the oil feed line (where it connects to the block) so got to get that squared away.
I've just been so busy lately. Bought an 06 wrx with a bunch of mods on it a little while ago for a daily driver, and registering it/smogging/removing and selling some of the stuff on it leave me no time to work on the miata

Last edited by 18psi; 03-04-2009 at 11:10 PM.
18psi is offline   Reply With Quote
Old 03-04-2009, 07:30 PM   #53
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

stock fans > egay fans.
patsmx5 is offline   Reply With Quote
Old 03-04-2009, 11:11 PM   #54
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

The drivers side will not clear the sway bar unless I hack it to hell. there is simply no room for it. the passenger side one is retained, while the drivers side one (the main one I guess) will be slim.
18psi is offline   Reply With Quote
Old 03-04-2009, 11:16 PM   #55
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by 18psi View Post
The drivers side will not clear the sway bar unless I hack it to hell. there is simply no room for it. the passenger side one is retained, while the drivers side one (the main one I guess) will be slim.
If you can make the stock fan fit, do that. Egay fans suck ballz and you loose your shrouding.

This is why I kept the radiator in the stock spot.
patsmx5 is offline   Reply With Quote
Old 03-18-2009, 04:59 AM   #56
Elite Member
iTrader: (1)
 
NA6C-Guy's Avatar
 
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 43
Default

Any more updates? Cant recall seeing if you had it up and running yet.
NA6C-Guy is offline   Reply With Quote
Old 05-17-2009, 12:08 AM   #57
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

Yes there are updates, well sort of. I have driven the car a little bit and sorting everything out slowly, BUT have been crazy busy the last month or so with the subaru and with my new job. So the progress is minimal but its there. STILL havent dropped in the slim fan, but here is what I did do:

Goodbye stock injectors


Hello rx7 cleaned/tested 460's


Check out how I routed the water lines: both hard lines that will not crack/blow/or anything else. Just the way I like it


Also notice I welded on a few more nipples to the intercooler piping to eliminate a bunch of vacuum lines going all around the engine bay. The ones I'm using now are short and hopefully trouble free


Welded on GM ait sensor and wired it in


Cleaned up the MAP sensor wiring, soldered it (finally) and mounted it in a decent place.


Picked up some heat shielding material to cover up the huge gap in rad support and rad/ic......That will be a project for next week or so.



So yeah, I'm slow as **** and it really annoys me, but there is just so much other stuff going on right now that I can barely keep up.

I'll most likely have it back up and running next week or so, just need to throw in the new map for the 460's so I can get this thing to idle/start properly. Then its on to autotuning as well as installing my hallman mbc and turning it up to about 10psi


-Vlad
18psi is offline   Reply With Quote
Old 05-17-2009, 12:14 AM   #58
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

Here are the ladies the way they sit in my garage as of this morning



Progress on the subaru can be found in this thread.
18psi is offline   Reply With Quote
Old 05-17-2009, 02:26 AM   #59
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,107
Total Cats: 518
Default

yo bra, yr bov ain't gonna work like that.

It needs to see vacuum to pull open the valve, if I'm not mistaken. Needs it's vacuum line hooked up post throttle body. On NA's, there are two nipples on the top of the throttle body, I don't see them on yours.
curly is offline   Reply With Quote
Old 05-17-2009, 03:29 AM   #60
Senior Member
iTrader: (3)
 
Join Date: Aug 2005
Location: Gig Harbor, WA
Posts: 504
Total Cats: 3
Default

Did Deatschwerks measure the lag time for those 460s?
TurboRoach is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:40 AM.