Miata Turbo Forum - Boost cars, acquire cats.

Miata Turbo Forum - Boost cars, acquire cats. (https://www.miataturbo.net/)
-   Engine Performance (https://www.miataturbo.net/engine-performance-56/)
-   -   Idle problems with motor swap (https://www.miataturbo.net/engine-performance-56/idle-problems-motor-swap-35150/)

mtbgael 05-16-2009 05:13 PM

Idle problems with motor swap
 
Hey all- first off here is my setup

70k '99 motor in a 1990 chassis (Naturally aspirated for now)
stock '90 ECU
RX7 MAF
'99 injectors/rail/etc.
'90 FPR.
Swapped all '90 sensors, etc as per the usual flyin miata swap. '90 Throttle body.

When I first did the swap everything ran FINE. Idled at 13-1400ish cold, 800 warm. Autocrossed the car once, and it idled high the rest of the day/drive home, then returned to normal. Autocrossed the car again and the idle was high from there out. ~2kish when warm. I adjusted the idle screw all the way down to make it livable, but now it idles at about 800 cold and 1200 warm. Any ideas as to why the idle would have just reversed like that? I was going to just megasquirt it and assumed that would solve the problem, but fixing the problem instead of covering it up would be preferable :laugh: FYI- when the problem first showed up I was running the '90 MAF, the second time it showed up (when it never went away) I was running the RX7 one.

TIA

hustler 05-16-2009 10:19 PM

just swap to ms.

Fireindc 05-23-2009 05:34 PM

My car idled terrible before I went ms. Perfect idle with minimal droop now with ms.

I assumed my problem was the afm. Not sure though.

mtbgael 05-23-2009 07:53 PM

Thanks...haha I guess I'll just MS it.


All times are GMT -4. The time now is 05:31 AM.