Miata Turbo Forum - Boost cars, acquire cats.

Miata Turbo Forum - Boost cars, acquire cats. (https://www.miataturbo.net/)
-   General Miata Chat (https://www.miataturbo.net/general-miata-chat-9/)
-   -   WTF happened to my car?!?! Loud top end noise? (https://www.miataturbo.net/general-miata-chat-9/wtf-happened-my-car-loud-top-end-noise-80301/)

BTMiata 08-05-2014 12:32 PM

WTF happened to my car?!?! Loud top end noise?
Ok so attempted to install my turbo set-up this past weekend. Manifold was wrong, so I put everything back to stock. I never even unplugges the stock ECU before putting the stock stuff back on. CAS was never touched.

The only things I took off/ put back on were...

-Drained Oil (Topped off before attempting to start)
-All exhaust parts
-All intake parts

WTF could have happened here?!?! Is this just a crazy coincidence? I seriously doubt it... Any ideas?

curly 08-05-2014 12:53 PM

Holy shit that's a fucked motor.

You sure you didn't remove the spark plugs and drop something in? Are you sure you reinstalled your oil drain plug? You can't fuck up a motor by removing the exhaust and putting it back on. Was something dropped while the exhaust manifold was off?

shuiend 08-05-2014 01:01 PM

Sort of sounds like very bad lifter tick, but I could be completely wrong.

Braineack 08-05-2014 01:05 PM

sounds like dead motor tick.

BTMiata 08-05-2014 01:34 PM

It started normal yesterday but had a leaking Injector o ring. I replaced that today and at first it clicked like a dead battery would. Put a jump box on it and it still wouldn't turn over. I moved the crank with a breaker bar and the motor was free. Then I tried again and it started but ran like this.

BTMiata 08-05-2014 01:35 PM

Spark plugs were never pulled... Didn't drop anything in the intake or exhaust that I know of... Wasn't missing any nuts /bolts either.

hornetball 08-05-2014 01:39 PM

So the motor was jammed somehow?

I think I'd pull the head for further inspection at this point.

BTMiata 08-05-2014 01:45 PM

Yeah the motor might have felt a little jammed but I didn't have to force it that hard when I had the breaker bar... Does that sound like something could have fell in the motor?

concealer404 08-05-2014 01:56 PM

Put a fork in her, Brian. :(

Time for a 1.8 swap to use your manifold anyways.

BTMiata 08-05-2014 02:02 PM

I'm going to look for a motor.... Whatever I find first goes in. This really sucks I can't believe all this right now

shuiend 08-05-2014 02:06 PM

The NJ Miata Mafia should be able to help you find a motor.

BTMiata 08-05-2014 02:12 PM

But wait how did it start yesterday and run perfectly and quiet ?!?! Something not adding up. It started and ran normal it just had a leaking Injector. This morning I got new o rings, replaced them and put the injectors back in and bam... Noise.

BTMiata 08-05-2014 02:13 PM

And yeah I have a post on new Jersey miatas

Braineack 08-05-2014 02:36 PM

did you put oil back in it?

BTMiata 08-05-2014 02:47 PM


Originally Posted by Braineack (Post 1154606)
did you put oil back in it?


pdexta 08-05-2014 02:50 PM

Have you pulled the spark plugs yet?

y8s 08-05-2014 02:57 PM

I'd re-check the oil level too. And what's all that smoke?

shuiend 08-05-2014 03:02 PM


Originally Posted by y8s (Post 1154616)
I'd re-check the oil level too. And what's all that smoke?

The smoke seemed like a normal amount for touching the header with your greasy hands.

concealer404 08-05-2014 03:10 PM

Did you drop an injector part down into the intake manifold, and subsequently, your motor?

BTMiata 08-05-2014 03:14 PM

Pulled plugs earlier but didn't see anything in the cylinders. My stock injectors still had all pieces in tact. My fic injectors still have all the pieces.... So I don't think I lost any Injector parts

The smoke is from penetrating oil burning off

All times are GMT -4. The time now is 10:47 PM.