90-93 Link Ecu IAT and knock sensor issue HELP - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


LINK Discussion about the LINK ECU.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-27-2013, 12:50 AM   #1
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Birmingham, AL
Posts: 254
Total Cats: 3
Default 90-93 Link Ecu IAT and knock sensor issue HELP

I have a Link MK1 that was upgraded to run, wideband, knock sensor, and intake air temp sensor. I was hoping someone may have a picture of an upgraded MK1 ecu on both sides. So, I can compare and make sure mine was upgraded correctly. I am not getting a reading from the knock sensor or the iat. I have moved the ground on the IAT sensor to a few different places. Any suggestions or help would be appreciated.
kww502 is offline   Reply With Quote
Old 05-27-2013, 05:19 PM   #2
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Birmingham, AL
Posts: 254
Total Cats: 3
Default

here are a few pics of the upgrade.


Name:  EE65DD77-2529-40BD-8D70-4A483146BFCF-593-0000004175ECD8F4_zps91e59fa2.jpg
Views: 6
Size:  175.5 KB
back of the ecu

Name:  36AEDE03-FF85-4B97-9706-D1E7A7657A34-593-00000040F198756A_zps8695bf82.jpg
Views: 6
Size:  166.2 KB
front of the ecu

Name:  A49ED8EB-EFCF-4404-A26B-AACFF37FE8E1-593-000000418596B77E_zps36991e6e.jpg
Views: 6
Size:  137.6 KB
this is the wire that I jumped to in the diagnostic connector from the Map harness which carries the signal from the knock sensor thru the Map sensor. I was hoping someone could verify that the wire is in the correct spot. I verified that it correlates with the pin in the ecu marked for knock.

Name:  BAD22305-4AE6-4034-A1A8-3508A6CB57DF-593-000000418D87BAE6_zpsa58e29be.jpg
Views: 6
Size:  140.8 KB
This is the wire that is hooked up to the IAT sensor.

Name:  59C6FA32-8B36-49DE-8170-140CA573A141-593-0000004193673C44_zps593d02e2.jpg
Views: 6
Size:  229.9 KB
This is one of the spots I attempted to ground the IAT sensor to.

Name:  904AAE17-BEE5-438A-88D5-E13A4B3160CC-593-000000419D162320_zps64d5183a.jpg
Views: 7
Size:  129.6 KB
Here is the other spot I grounded the IAT too, thinking I had a bad ground.

Well wiring and electronics are not my strong point so I was helping someone might be able to see where I obviously made a mistake. I am open to ideas and know most of the guys on here know a lot more than I do.
kww502 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:15 PM.