Miata Turbo Forum - Boost cars, acquire cats.

Miata Turbo Forum - Boost cars, acquire cats. (https://www.miataturbo.net/)
-   MEGAsquirt (https://www.miataturbo.net/megasquirt-18/)
-   -   '99 DIYPNP - DB9 Power, Bluetooth Connection, and EBC (https://www.miataturbo.net/megasquirt-18/99-diypnp-db9-power-bluetooth-connection-ebc-79471/)

acedeuce802 06-11-2014 12:20 AM

'99 DIYPNP - DB9 Power, Bluetooth Connection, and EBC
 
6 Attachment(s)
Hey there, I have a '99 with a DIYPNP that I believe to be built by Brain a while back. Pictures are below of the board. Seems to have A/C control, sequential injection, and EBC, but no launch control. I did figure out the wiring of the launch control, though. The end of my USB cable corroded a little and would no longer connect to my laptop, so I took the opportunity to purchase EFI's RS232 connector. When plugging into the DB9 port (using a 3 ft. DB9 extension) it get's no power, none of the lights are illuminated. I tried using the supplied power cable hooked up to my computer, and I'm able to connect to the computer. A few issues, though. The red light on the bluetooth module is always on, and the blue light blinks, until I manually press the connect button in the settings on the laptop, and the blue light becomes solid. About 1 or 2 minutes later, the blue light blinks again, and disconnects. Even when the bluetooth module is connected, I cannot connect to Tunerstudio. I've checked what COM port the bluetooth module is connected to and selected that, I've tried using the detect feature, but Tunerstudio won't connect. It does recognize the new COM port, because COM6 only showed up after I got the module connected to the laptop, but will still not connect to the ECU. Any ideas to why this won't connect?

The next thing to resolve is why pin 9 doesn't seem to be getting power. The only documentation on that I found was related to MS1, where pin 9 was grounded. I'm not sure how to go about this, since I'm not sure how to trace where pin 9 goes to on the circuit board.

Lastly, I see the circuit is there for EBC, but the IN and OUT ports are not filled. Where do these get populated? I know one wire from the EBC solenoid ends up getting grounded to the middle prong on the FET, and can go through the DB15 connector, but does that just get jumpered to either IN or OUT?

Bear with me, I'm a mechanical guy, this is my first time touching this kind of stuff!

https://www.miataturbo.net/attachmen...ine=1402460411

https://www.miataturbo.net/attachmen...ine=1402460411

https://www.miataturbo.net/attachmen...ine=1402460411

Braineack 06-11-2014 09:09 AM

is the jumper next to the DB9 installed (BL/TH) on both pins, or just the one? (it doesn't appear to be)

those pins needs to be bridged in order to send 5v to pin 9 on the DB9.



Launch in can be wired like this:

4I > Input 2 IN
Input 2 Out > FLEX

acedeuce802 06-11-2014 09:34 AM

Quote:

Originally Posted by Braineack (Post 1138982)
is the jumper next to the DB9 installed (BL/TH) on both pins, or just the one? (it doesn't appear to be)

those pins needs to be bridged in order to send 5v to pin 9 on the DB9.



Launch in can be wired like this:

4I > Input 2 IN
Input 2 Out > FLEX

I'll have to check that tonight, it's hard to see from the pictures I took. In the last picture, is that the two pins right next the letter "M" in .COM?

Right now I have 3I to Input 2 IN, and Input 2 out to FLEX. Why use 4I? Isn't 3I the clutch switch from the harness?

Braineack 06-11-2014 09:46 AM

yes. the picture above it shows the jumpers, doesn't appear to be bridging the connection. By default i don't tend to connect them, so that makes sense.

because the numbering on the DIYPNP ECU doesn't match the numbering on the Factory ECU.

acedeuce802 06-11-2014 09:51 AM

Cool, thanks for the help!

acedeuce802 06-11-2014 11:53 PM

I now have power to bluetooth, it's connecting perfectly to both my laptop and phone, and launch control and flat shift work! Thanks again!

Braineack 06-12-2014 07:51 AM

:bigtu:


All times are GMT -4. The time now is 05:39 AM.