Miata Turbo Forum - Boost cars, acquire cats.

Miata Turbo Forum - Boost cars, acquire cats. (https://www.miataturbo.net/)
-   MEGAsquirt (https://www.miataturbo.net/megasquirt-18/)
-   -   cylinders 2 and 4 running rich :confused: (https://www.miataturbo.net/megasquirt-18/cylinders-2-4-running-rich-confused-21944/)

kotomile 06-04-2008 01:36 PM

cylinders 2 and 4 running rich :confused:
 
4 Attachment(s)
So I'd been wondering why in the hell my car was cruising/idling/everything pig rich (like 11.5 and richer CONSTANTLY) and thought I'd change my plugs. This is what came out, cyl 1 on left, 4 on right:

Attachment 212784
Attachment 212785

So, judging by those, I don't think it's my tune...

Here's two logs, just driving normally to and from work:

Braineack 06-04-2008 01:53 PM

are you even getting fuel in 1 and 3?

kotomile 06-04-2008 01:58 PM

I would think so? There's a bit of soot on them, just not as much as 2 and 4.

Ben 06-04-2008 02:03 PM

I don't know dude, I'd clean/replace the plugs and look again in a few days.

Saml01 06-04-2008 02:05 PM

Swap injectors around.

Arkmage 06-04-2008 02:08 PM

I'd try swapping your injectors around and see if the problem moves with them. You might have two leaky ones.

*edit* sam beat me to it.

Ben 06-04-2008 02:08 PM

maybe, but not unless/until the symptoms repeat.
identify a problem before looking for a solution.

kotomile 06-04-2008 02:35 PM

I should mention the car idles like a Subaru and bucks a lot during cruise, definitely NOT smooth anymore. I remember the cylinders are batch-fired and was wondering if that might have anything to do with it.

Ben 06-04-2008 02:44 PM

i think the batches are 1+2 & 3+4. a quick trip to madracki would tell for sure.

Braineack 06-04-2008 03:32 PM

spark is 23 14
fuel is 13 24

Braineack 06-04-2008 03:37 PM

I'd assume you are getting spark on all 4 since its running super as nasty rich on 2 and 3 and the way its batched....

so either you have 2 dead injectors, or two leaky injectors, or im completely wrong.

kotomile 06-04-2008 03:46 PM

Leaky injectors would be a good explanation, but the fault in it is that it might not be that likely that both 2 and 4 started leaking simultaneously.

I just got the taillight too man, thanks!

Matt Cramer 06-05-2008 01:14 PM

Could you post your MSQ? I'd like to take a look and see if there are any settings for different fueling on the separate injector channels.

Braineack 06-05-2008 01:48 PM

http://img256.imageshack.us/img256/1...eltablexd2.gif

im sure Matt speaks of this....

kotomile 06-05-2008 03:25 PM

Quote:

Originally Posted by Matt Cramer (Post 267069)
Could you post your MSQ? I'd like to take a look and see if there are any settings for different fueling on the separate injector channels.

Absolutely, at work now but I will later for sure.

AbeFM 06-05-2008 03:39 PM

Curious where that goes. I'm wondering if something burned out in the MS, just leaving the injectors on. That, or a short somewhere.

Did it happen suddenly? Does it always do it, or is it on and off?

kotomile 06-05-2008 06:22 PM

1 Attachment(s)
Here's the .msq \/

Abe: That's what I was thinking might possibly be the problem, but didn't want to jump to that conclusion lest it be something more simple.

It always does it, I can't remember when it started but it hasn't let up since I first noticed it happening. It's like clockwork; after startup, AFRs will be around 15:1, then climb to 17:1ish, then drop steadily to 11.5ish, sometimes 10:1 in cruise. Just measured my MPG - 16 MPG...

AbeFM 06-05-2008 06:30 PM

Oh, it doesn't happen for a while?

If you run it for a while, 20 min or something, shut it off then immediately start it again, how is it?

I wonder if it's electronics heating up....

Braineack 06-05-2008 06:32 PM

post a log too. needs more log.

Braineack 06-05-2008 06:34 PM

your ego settings and AFR table are screwy.


RPM Based ACCEL needs to be off.


ASE table should go to 0% at 160*


timing and fuel tables at idle look crazy low.


overboost is at -5.7psi, might screw things up.


All times are GMT -4. The time now is 11:32 AM.