Engine falls flat after ~6,800, can't figure this out! - Page 6 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-25-2015, 04:24 PM   #101
Junior Member
 
Join Date: May 2015
Posts: 86
Total Cats: 10
Default

Just another word about part throttle vvt. When I tune this on OEM projects, we run it on an engine dyno at steady speed and load and sweep cam position. The more the cams move (depending on the grind), the crappier the engine runs generally speaking. So you try to see how much VVT you can use to decrease fuel consumption and emissions without a driver being able to notice it. You make charts of vvt position vs how shitty it is running (combustion pressure fluctuation metric).

The entire point of part throttle vvt is to make the engine run worse in the name of fuel economy and emissions. The difference is, the OEMs have the resources and need to make it seamless. For hobby applications, it has minimal real world benefit and should be treated more like a science experiment to mess with when you've finished higher priority tasks.
arghx7 is offline   Reply With Quote
Old 05-25-2015, 04:31 PM   #102
Elite Member
Thread Starter
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Thanks for the explanation. This is a street car and driveability is much more important to me than a tiny change in mpg or emissions.

For now I'm getting other little things fixed/finished on the car (flush brakes and clutch system, reinstall undertray, diy heat shielding for exhaust system) but I'll get back to tuning soon! Will get my old det cans hooked up too so I can listen for detonation.

If you listen to the video I posted of the car ripping in 2nd, you can hear the engine is "louder" up to ~6500 and then it gets a lot quieter. It also goes a lot slower when it gets quieter, and virtual dyno confirms both peak Torque AND peak Horsepower both happen right at ~6,500 when it gets a lot quieter.....

I don't know what this means, just an unexplained observation at this point. But I think it means something.
patsmx5 is offline   Reply With Quote
Old 05-25-2015, 04:36 PM   #103
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

You mentioned running a fan pretty much all the time when the ignition is on, and the need of a bigger alternator to run both fans because they are big? Is it possible alternator load could be messing with you?
deezums is offline   Reply With Quote
Old 05-25-2015, 04:43 PM   #104
Elite Member
Thread Starter
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

It is possible. That is one thing I have not found a solution for. If it is a problem, it's the voltage not staying high enough.

The fans run on LOW all the time with key in On position, it's about 17A. This seems to be ok for the most part. Voltage is pretty steady at most Loads/RPMs. A/C on at idle with headlights on when the car is hot, the alternator struggles. If fans go high (~70A), volts drop to the 11s....

I'm going to return a Amazon 140A alternator I bought and probably try buying a 200A generic chevy alternator and get it mounted and see if it can keep up. The 140A worked sort-of-ok when the engine was cold, but when it heatsoaked the alternator output dropped to that of my stock 70A alternator.
patsmx5 is offline   Reply With Quote
Old 05-25-2015, 06:28 PM   #105
Junior Member
 
Join Date: May 2015
Posts: 86
Total Cats: 10
Default

Is there a reason why you don't have the megasquirt controlling a fan relay based on temperature, rather than using the ignition circuit?
arghx7 is offline   Reply With Quote
Old 05-25-2015, 06:35 PM   #106
Elite Member
Thread Starter
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by arghx7 View Post
Is there a reason why you don't have the megasquirt controlling a fan relay based on temperature, rather than using the ignition circuit?
Yes. I have a pair of 12" Spal Extreme performance fans. They pull about 35A each. I built a series/parallel fan controller so I can run them on Low (~17A) and High (~70A)

The Intercooler is about 3/8" away from the radiator in my setup, so I keep the fans on low so that the IC never heatsoaks when at low speeds. If I turn the fans off the air intake temps shoot up due to the close proximity.

The HIGH circuit is controlled by the MS3 and it goes high if coolant or air intake temps get too high.
patsmx5 is offline   Reply With Quote
Old 05-25-2015, 06:50 PM   #107
Junior Member
 
Join Date: May 2015
Posts: 86
Total Cats: 10
Default

You could still reduce battery drain by having the ECU control the low setting and an external thermoswitch on the high setting, assuming you don't have enough ECU outputs to use 2 just for fans. That's common on Rx-7 applications. For example, you want to control heatsoak but you still don't need the fans coming on as soon as you turn the key in the morning before you even start the engine. It would still benefit to control the low temp mode based on a set of criteria rather than with the ignition circuit.

Low temp would be signaled by the ECU at one temperature, based on how you set it up, and high temp would come on at some other speed. I don't know the exact details of your setup but Miatas did come with thermoswitches from the factory that you could use.

There's also the starion thermoswitch or other options. These are just threaded switches with a spade connector or single pin connector that switch a ground when the temperature is reached, and then turn off with some hysteresis. They're not those silly push-in radiator things. Those suck.
arghx7 is offline   Reply With Quote
Old 05-25-2015, 07:40 PM   #108
Elite Member
Thread Starter
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

I will probably do that once I get all the thermocouples working. Until then it's just on low with key on. Based on how it performs, they could go off when cruising.

I still gotta figure out a better alternator though. I found a 200A chevy alternator for ~200 I'm thinking about trying next. Also found a 220A one that looks better, but it's ~350 bucks! Ouch...
patsmx5 is offline   Reply With Quote
Old 05-25-2015, 09:10 PM   #109
Elite Member
 
DNMakinson's Avatar
 
Join Date: Jan 2013
Location: Seneca, SC
Posts: 2,708
Total Cats: 269
Default

Arghx7:

2 questions:
1) In the VE table you posted above, is MS fueling equation, "Include AFR", or is the enrichment included in the table.
2) In either case, what AFR targets are you shooting for?

Question 2 is of interest to me mostly because we have lots of conversations here with some successful tuners using a somewhat lean approach, and other a somewhat rich one. The question is important because a dyno tune that is set up to hit the targets presumes those targets.

Question 2 also because I see in step 4 you tuning spark for max torque, but I don't see that in step 2 for fuel.

Pat, I hope you don't mind me diverting the thread a bit.

DNM
DNMakinson is offline   Reply With Quote
Old 05-25-2015, 09:54 PM   #110
Elite Member
Thread Starter
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Carry on sir! This thread is getting awesome, lots of good info in here, more will make it better!

I use Incorporate AFR on my setup. And I'm tuning for 11.0:1 in boost. I tried running a lot leaner on last motor, it detonated and broke a piston, even with A TON of water injection.
patsmx5 is offline   Reply With Quote
Old 05-26-2015, 08:41 AM   #111
Junior Member
 
Join Date: May 2015
Posts: 86
Total Cats: 10
Default

Quote:
Originally Posted by DNMakinson View Post
Arghx7:

2 questions:
1) In the VE table you posted above, is MS fueling equation, "Include AFR", or is the enrichment included in the table.
You know, I forgot about that setting. I just checked and it's on. The AFR target table is in mid 11's under boost, but closed loop authority turns off once it gets out of what I'd consider cruising boost range.

If I had thought about it earlier I would have just turned turned include AFR off, but the numbers are working out right now and there's no sense in going through the work of turning it off and messing with it. I never touched the AFR target table in that area, so by my understanding those are just constant multipliers and not having a big effect. To a certain extent it doesn't matter insofar that you want a final result and they're all just multipliers.

I don't use autotuning functionality either--not that it doesn't work, but you need to filter a lot of crap data out to not get craters in your VE map. You can manually tune a few cells and interpolate everything else if you understand the engine's response curves to various factors.

I've seen remarks about having a very smooth VE table. The vast majority of this table was extrapolated and interpolated. It took about an hour to make this table initially on the street, and then about an hour and a half for final tweaking on the dyno. It was created by me using a sort of simplified Design of Experiments method mostly performed in my head and in MS Tuner Studio.

Design of experiments is kind of a catch-all thing, but it's a way to drastically cut down the time and effort needed to tune something. It's used on the OEM level. There are a gazillion combinations of air, fuel, spark, etc parameters that can be used under any engine condition. So for a VE map, what you do is tune certain cells and take what you learn to train a model of the engine. The model then populates the rest of the cells. Commercial software like ASMO by ETAS will do this for you, and much of it is designed for engine dynos in expensive labs. In your own mind, you just have understand sensitivity of the engine to certain parameters and use that to help you interpolate and extrapolate.


What I did was this:

1. Scale even breakpoints in as much of the map as possible. This is important. It's to keep from having the interpolation produce wacky values. It's different from the "have fine resolution in a certain area" approach. So I might go in even 500rpm steps for the speed axis as much as possible, and only change spacing once if that's needed at all.

2. Tune a few cells in the low load and cruising range. You can use auto tuning if you want to, but you have to hold the engine pretty steady at the speed and load. It's easiest with a loading dyno but that's often not an option.

3. Tune a few cells in the low boost range.

4. Figure out % difference in fuel requirements (VE values) between cells, trying to hold boundary conditions consistent (similar charge air temperature for example). This is the key. Ever used a boost compensation table in AEM EMS? It works off this principle.

If I need 55% VE at 2500rpm and 50kPa MAP to achieve a 14.0:1 AFR, and I need 58% VE setting at 3000rpm and 50kPa, what does that tell me? 58 divided by 55 is 1.05 . So if I take all my values at 2500rpm, copy them into 3000rpm column, and multiply by 1.05, I now have a smooth transition in VE with rpm.

It's actually easiest to do this with RPM, because the cylinder filling is directly related to the intake valve closing timing, and a normal even-fire I4 engine doesn't have too many weird exhaust tuning effects.

With boost, well I am now answering the question - if I go from 100kPa MAP to 110 kPa, what is the percent difference between the two values? I go ahead and tune 2500rpm at 100kPa and 110 kPa to say 13:1 AFR. I get 80% VE at 100kPa 81% at 110kPa. Divide the two numbers, and I get 1.0125 . So if I want to keep the same AFR, I can estimate that I need to add 1.25% fuel per 10kPa of boost. So I take all the VE values at 100kPa MAP, copy them to 110kPa, and multiply by 1.0125 . Take that new set of values, go to 120 kPa, paste them in, multiply by 1.0125.

Now here's where it gets tricky. We know we want to get richer with boost eventually, so it's easiest to bias the slope of the VE table. I may take my values at 140 kPa, copy them to 150 kPa, and multiply by 1.02 . Now I'm biasing rich.

You jump back and forth among actually capturing datalogs, adjusting VE vs RPM slopes, and adjusting VE vs MAP slopes. I pretty much do it in my head because I've been doing it for a long time. There are more meticulous ways to do it.

So then you go look back at your VE table and do the following checks:

1) does my VE increase with rpm, up to the point of best cylinder filling according to the valve timing? If it doesn't, I'm going to get lean spots. On this stock 1.6 Miata cam, best cylinder filling is at about 4500rpm. Later intake valve closing timing (longer duration cam or more retarded intake cam phasing on VVT engines) changes the point of max cylinder filling. After that rpm, VE should be flat or start to go down. if it doesn't, you will go rich.

2) does my VE increase with MAP? If it doesn't, I'm going to get lean spots. It should get richer (VE # % increase higher) at a faster rate as you get into heavier and heavier loads. This accounts for airflow from the turbocharger.

3) If I drive around without wideband o2 feedback, is my AFR jumping around like crazy? if it is, you probably have too many dips in the VE table.

4) If it's smooth with O2 feedback off, but AFR's get jumpy with it on, look at your AFR table setpoint and look at your controller games. I usually tune the gains for slow, steady response, with a smaller P gain




Quote:
2) In either case, what AFR targets are you shooting for?
It's working out to be a flat 11.0:1 at full boost. Now, that's not because I am strongly wedded to that. It's just that the resources aren't available to do a more detailed study of optimum AFR for this engine, and a certain safety factor needs to be incorporated in.

Quote:
Question 2 is of interest to me mostly because we have lots of conversations here with some successful tuners using a somewhat lean approach, and other a somewhat rich one. The question is important because a dyno tune that is set up to hit the targets presumes those targets.

Question 2 also because I see in step 4 you tuning spark for max torque, but I don't see that in step 2 for fuel.
It just depends how much time you want to spend, and what your assumption for AFR drift over time is going to be. I usually assume 0.5:1 fluctuation throughout a year's worth of driving in 4 seasons. You can get it tighter than that if you have load-based air density correction, to account for things like the "I stopped at 7 Eleven for a Slurpee and my manifold air temp sensor is now heatsoaked" scenario.

The engine held up to a bunch of Tail of the Dragon runs before it ever made it to the dyno, so I consider that a success. The more engines you have to mess with the more you can study these factors, because you're not afraid to blow one up catastrophically or wear it out by beating on it. Race teams might have a couple engines, and OEMs have dozens if you include all the development phases.

For example, take knock control. Severe knock is obvious, but at the margins, Knock control is pretty much one guy's opinion on how much is too much. That applies whether you are using detcans, microphones, the naked ear, cylinder pressure traces on an oscilloscope, or calculated knock metrics from cylinder pressure (knock peak and intensity).

I've done knock sensor studies before and you really need to go through a whole procedure just to set the knocking frequency and the placement of the sensors. Then you need to set the gains and the knocking thresholds.

This really has to be done initially on an engine dyno by inducing knock in the engine and comparing accelerometer data, cylinder pressure data, and knock sensor data. You can't do that on your home project. The resources aren't available. So maybe you go off what somebody else's frequency is, and you look for spikes or unusual knock activity, or you attempt to tune with detcans. You could even induce some knock on a loading dyno at low speeds at least where it's less risky. Even then, you gotta make a judgment call.

Hope that helps. Just remember that there's physics and then there's the fudge factor built into the tune. You have to be able to understand and mess with both.
arghx7 is offline   Reply With Quote
Old 05-27-2015, 01:47 AM   #112
Junior Member
 
Join Date: May 2007
Location: Toronto Area, Ontario
Posts: 139
Total Cats: 29
Default

Quote:
Originally Posted by patsmx5 View Post
It's possible, as when I shut the water injection off the car clearly makes more power. It's off now though (pumps off, outputs off, pressure is low), and power is still down and falling off despite airflow going up, Duty cycle going up, etc.
Did you get the water injection working again?

From your earlier post, you're running water injection for 2 reasons;
1. To suppress knock,
2. to keep your supercharger cool.
oreo is offline   Reply With Quote
Old 05-27-2015, 02:38 AM   #113
Elite Member
Thread Starter
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

It is currently off. I need to troubleshoot a leak as pressure does not hold when I shut the system off like it should. This is something I have not yet looked into but I will.

And yes the reason I installed it is because I want to make a lot of HP on pump gas, and I believe I'll need it to suppress detonation.
patsmx5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:11 AM.