When auto-tuning with VE Analyzer Live - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-06-2011, 05:12 AM   #1
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default When auto-tuning with VE Analyzer Live

Someone please school me on this **** so that I stop getting inconsistent autotuning:

The problem-
Weather is extremely inconsistent here right now, so days are very warm and nights are super cold. I can pretty much only tune at night (due to work and local traffic).
Each time I go out and autotune the car for an hour or two it runs like an absolute princess and I'm in love with it.
Days pass and the weather/temps change and it still runs good, but nowhere near as nice and afr's are nowhere near as consistent as the time I tuned it.



The question
-
Is there certain things that need to be enabled/disabled when autotuning, and what other settings could be causing the inconsistencies?

I've smoothed it over and got it to be more or less decent, but want to ensure that my **** is running tip top year round and I don't have to keep tinkering with it every month or two.

screenshot





My msq is attached.
Everything I can think of is set up correctly, ait correction/enrichments/etc, my maps are pretty smooth and have no major spikes/dips that I can see.

so what am I missing?
Please help me out.
Attached Files
File Type: msq 2011-02-05_20.43.18.msq (79.1 KB, 71 views)
18psi is offline   Reply With Quote
Old 02-06-2011, 05:53 AM   #2
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,107
Total Cats: 518
Default

Have you tried tuning during the day? Seems like if your drive to work doesn't feel as nice, you should take a quick log, tune for the higher ait's.
curly is offline   Reply With Quote
Old 02-06-2011, 06:01 AM   #3
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

I've tried tuning during the day.
I've tried tuning during the night.

The car runs GREAT. After a major climate change it runs just "good". Meaning I can't complain, but I want to figure out which one of my enrichments or settings is not adjusted properly and make it ALWAYS run great like right after autotune.

Maybe I'm just being too OCD about it? dunno


ALSO,
I did one of those "idle valve tests" today as per this post
Quote:
Originally Posted by Braineack View Post
yes, run the car. go to idle valve test mode, and plug in the number you want to sit the valve at. if you put in 0, the valve will be fully closed. Increase it until your idle speed acutally rises. Then you know this is the lowest dc% number that acutally works the valve. Keep going up until you find the highest value that increases the engine speed. Then you know what the max dc% is.

You'll have to restart the car in order to go back to normal idle.
in this
https://www.miataturbo.net/showthrea...highlight=idle

Thread and nothing happened. At all.

My idle is decent, but I have a very tiny oscilation every 5 seconds or so. Its very small, like 100 rpm or even less, but its annoying. Trying to get rid of it and no luck yet.


Turned on "idle testing enable"
changed from "run" to "home" and back and increased/decreased iac step value.
No matter what number I plugged in for it nothing happened.
18psi is offline   Reply With Quote
Old 02-06-2011, 06:04 AM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

If you have closed loop fuel control at idle enabled, I would disable it. Closed loop + 1000cc injectors = bad.
Reverant is offline   Reply With Quote
Old 02-06-2011, 11:11 AM   #5
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

And to answer your original question...we need logs and MSQs. Get your car tuned as best as you can, datalog your "ideal" run, post your datalog and MSQ in this thread, then when you think that its good but not as good as "that previous day", datalog again and post in thread so that we can compare.
Reverant is offline   Reply With Quote
Old 02-06-2011, 06:21 PM   #6
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

Ok will do.
And where do I look for the closed loop fuel control at idle? Is that in "startup/idle" -> "idle control"?

Its at "PWM closed loop" right now.
18psi is offline   Reply With Quote
Old 02-06-2011, 06:46 PM   #7
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

EGO Control under Basic Setup. Set Active above RPM to 1400.
Reverant is offline   Reply With Quote
Old 02-06-2011, 07:01 PM   #8
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

Ah, I see.
Its set at 750 right now.
Will change asap. Thanx
18psi is offline   Reply With Quote
Old 02-06-2011, 09:44 PM   #9
Junior Member
iTrader: (4)
 
Join Date: Mar 2007
Location: Greece
Posts: 290
Total Cats: 4
Default

I have a similar issue with the tune during weather change. I think it is related with the mat enrichments. Where do you place your iat sensor?
gianic is offline   Reply With Quote
Old 02-06-2011, 09:45 PM   #10
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

My ait is after the intercooler before the tb.
About 10 inches away from tb.
18psi is offline   Reply With Quote
Old 02-06-2011, 09:58 PM   #11
Junior Member
iTrader: (4)
 
Join Date: Mar 2007
Location: Greece
Posts: 290
Total Cats: 4
Default

I think it is a decent spot.
What changes do you see in afrs? For example when I tune during night the next noon(warmer) the afrs are pretty fucked up. They are much leaner so I add fuel via mat enrichments. The problem is that this **** is a never ending story because I don't have a finished mat table yet. I am still correcting it.
gianic is offline   Reply With Quote
Old 02-06-2011, 10:01 PM   #12
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

Its not so much a change in afr's as inconsistency.
Like it will oscilate around a little more after a while as opposed to being RIGHT on targets when I autotune and right after.

Maybe I'm just nitpicking. lol
18psi is offline   Reply With Quote
Old 02-07-2011, 07:02 PM   #13
Elite Member
iTrader: (4)
 
MartinezA92's Avatar
 
Join Date: Aug 2009
Location: Mountain View, CA
Posts: 1,702
Total Cats: 28
Default

Hmm, I've been having this same problem. My AFRs stray .2-.5 after autotuning, and I can never get idle to be a consistent AFR. (I tune that myself, changing the VE table makes too big of an adjustment though...)

I should prob learn to mess with MAT. Fwiw, if I tune on a somewhat average day (70ish), my AFRs stay close enough whether its 30 degrees or 100 degrees outside. Still not right where I put em though.
MartinezA92 is offline   Reply With Quote
Old 02-07-2011, 07:11 PM   #14
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

I adjusted the closed loop fueling to 1200 last night and idle seemed to get MUCH more steady. Where before it would jump around between 14.0-14.7-15.2 it was a rock solid 13.9 last night. I'll have to lean it out a little bit but the oscilation seems to have disappeared at idle.


I'll have to double check that within the next few days to make sure its consistent though
18psi is offline   Reply With Quote
Old 02-07-2011, 07:22 PM   #15
Elite Member
iTrader: (4)
 
MartinezA92's Avatar
 
Join Date: Aug 2009
Location: Mountain View, CA
Posts: 1,702
Total Cats: 28
Default

So you're in closed loop at idle, and in open loop above 1200? What wideband are you running btw?
MartinezA92 is offline   Reply With Quote
Old 02-07-2011, 07:25 PM   #16
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

The other way around.
Reverant is offline   Reply With Quote
Old 02-07-2011, 07:27 PM   #17
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

yes that /\
and aem uego
18psi is offline   Reply With Quote
Old 02-07-2011, 09:08 PM   #18
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Did you actually measure your MAT correction? That looks like Brain's MAT correction table. I sat and idled my car when it was cold up to IAT temp of 102 degrees. My MAT correction looks nothing like that , it is also set to 50%.

My MAT correction looks more like

20 -3
60 0
70 0
75 -1
80 -2

When it warms up I will see if I need to add fuel at higher temps. I adjusted the MAT correction by adding or subtracting fuel until my idle AFR remained constant as the IAT changed. You will end up with 0 correction at the temp that you tuned your idle. It's best to tune MAT when it is bitter cold because the car can be warmed up (warm up enrichment off) and still have IATs in the 40s or lower.

Last edited by miatauser884; 02-07-2011 at 09:19 PM.
miatauser884 is offline   Reply With Quote
Old 02-07-2011, 09:45 PM   #19
Murderator
Thread Starter
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

Ya i'm a lazy bum and copied his as well as others.

I'll have to mess with it and dial it in perfectly like I had it on my adaptronic.

care to share yours? I'm curious how big the differences are
18psi is offline   Reply With Quote
Old 02-07-2011, 09:54 PM   #20
Junior Member
iTrader: (4)
 
Join Date: Mar 2007
Location: Greece
Posts: 290
Total Cats: 4
Default

How about a topic deticated exclusively sharing mat tables?
gianic is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 02:34 PM
"Chimney Ethanol" E100 MiataGarage Engine Performance 5 09-30-2015 12:04 AM
96 montego blue nOOb from Milwaukee Squiblez Meet and Greet 1 09-23-2015 02:50 AM
2015 NASA Eastern Championships at VIR emilio700 Race Prep 35 09-11-2015 01:23 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:11 PM.