MKTurbo NA/NB Turbo Setups - Page 32 - Miata Turbo Forum - Boost cars, acquire cats.

Miata parts for sale/trade Buy, trade or sell your Miata parts here.

MKTurbo NA/NB Turbo Setups

Old 07-09-2015, 08:47 PM
  #621  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 74,925
Total Cats: 2,080
Default

so a fin broke off? Time to clean out your IC...

I have a genuine Garrett 50 trim wheel that would probably work... iirc when i compare my trubo to the garret it was like identical.
Braineack is offline  
Old 07-09-2015, 09:26 PM
  #622  
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Texas
Posts: 1,147
Total Cats: 51
Default

Why the hell would it have snapped off though?
ScottyP3821 is offline  
Old 07-09-2015, 09:27 PM
  #623  
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Texas
Posts: 1,147
Total Cats: 51
Default

Edit.

I found it. It was wedged into the fins of the intercooler. It actually caused a little damage. But at least it's not in the motor!


Attached Thumbnails MKTurbo NA/NB Turbo Setups-80-image_2ac19805d74d842a2383b4f6290b8dfddf76c7e1.jpg  

Last edited by ScottyP3821; 07-09-2015 at 09:56 PM.
ScottyP3821 is offline  
Old 07-10-2015, 08:10 AM
  #624  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 74,925
Total Cats: 2,080
Default

you can probably buy this and be on your way:

WOW New Performance T3 50 Turbo Compressor Wheel | eBay

I'd measure my current wheel and see. the most important part is the inducer, i'll have to pull my pics but I was pretty certain the chrubo was identical to my 50 trim wheel.

you dont want a new wheel to make contact with the housing, and be in the same boat.


this wheel might also work: http://www.ebay.com/itm/Turbo-Compre...02c4aa&vxp=mtr

but that's a road i have not traveled.


or have Lars show his supplier the pics, and see if they'll replace it...
Braineack is offline  
Old 07-10-2015, 09:32 AM
  #625  
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Texas
Posts: 1,147
Total Cats: 51
Default

Im hoping this site is correct

Compressor Wheels - Garrett Racing - Applications - TurboMaster

but I believe the part number 409096-0014 is what Im after.

I converted inches to mm in the link you posted Scott but wanted to double verify. I measured my wheel last night but left the numbers at home. Ill double check tonight and if it work out Ill order the garrett. I just wonder what would have caused a fin to break like that.

I did have an old K&N filter on the intake side. I wonder if part of the metal mesh that was separating was pulled in there. Or maybe it was just bad material composition and it had a weak spot that snapped off. Either way the turbo has balancing marks so I should be able to throw a new balanced wheel on and not need to rebalance correct?

There isn't any wear on the inducer or back of the wheel so Im assuming it was balanced properly. The shaft play is acceptable from the Youtube videos I have watched. So its good there.
ScottyP3821 is offline  
Old 07-10-2015, 01:08 PM
  #626  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 74,925
Total Cats: 2,080
Default

I've ran plenty of bastardized frankenstein T3s and never had issue.

I had a 45 trim initially, swapped the coldside for a: t40e, 50 trim, then eventually the super 60.

I was going to swap the super 60 on the ebay turbine to see how is compared to the real garrett, but I got lazy and I really liked how the china t3 ran.


that looks like the correct wheel, I'll have to dig through my comparison photos, I remember noting the that it was hard to tell which was garrett and which was fake. really the only way was how new the one looked and the AiRearch stamp.

The turbines were very similar but the inducer on the china extended out an extra 5mm..I always wondered if thats why it spooled so much better and i wanted to try the s60 wheel on it to see if I could have cake and top-end too.
Braineack is offline  
Old 07-10-2015, 08:53 PM
  #627  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

Finally got everything back together, just need to lower the car put the bumper back on and add fluids. Everything fit very well, no problem with the a/c compressor or the power steering pump. I will post a few pictures and there will another one of us running this turbo soon.
sonofthehill is offline  
Old 07-11-2015, 12:42 PM
  #628  
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Texas
Posts: 1,147
Total Cats: 51
Default

Did you port it. IMO your really gonna want to port this little bastard well to prevent creep
ScottyP3821 is offline  
Old 07-11-2015, 01:23 PM
  #629  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

Lars said I didn't port it enough yet. I took it for a test spin to the gas station, runs good, only to got to 150kpa. It is still too rich in boost but I took a log so I will play with it some. It overheated at idle though on the way back so I need to let it cool so I can burp it better.
Runs nice, very quiet, I will report back after a burp and some tuning.


Here is a pic of the drain line going around the a/c compressor, which is something I wanted pics of before the install. I am very happy with how it turned out even though I didn't get to see a pic first.
Attached Thumbnails MKTurbo NA/NB Turbo Setups-80-img_20150710_191421750_4311970aab6c6b696eed9b6d471d4c7fc076758a.jpg   MKTurbo NA/NB Turbo Setups-80-img_20150710_182315424_ef2de562b778da0827527e40d4c05a2a6b85651e.jpg  
sonofthehill is offline  
Old 07-11-2015, 01:24 PM
  #630  
mkturbo.com
Thread Starter
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 14,072
Total Cats: 1,227
Default

I am deeply sorry my exhausts are to good for the turbo.
shuiend is offline  
Old 07-11-2015, 01:38 PM
  #631  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

I didn't even get past 5k rpm, still taking it easy as that was the first test drive, not to mention my waste gate is running directly off the compressor housing. I had to make sure I didn't forget to tighten something. I plan to take it out again later today, already adjusted some boosted cells but I was at about 10:1 in boost so it will still be pretty rich.
sonofthehill is offline  
Old 07-11-2015, 01:48 PM
  #632  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

Here is my waste gate port.
Attached Thumbnails MKTurbo NA/NB Turbo Setups-80-img_20150623_175524967_4ece7b471e560f6ecd7d59e9ff07d81c4a2c000d.jpg  
sonofthehill is offline  
Old 07-11-2015, 02:12 PM
  #633  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

I almost forgot that I am still missing 3 clamps, so I am likely leaking boost at the IC couplers. Does anyone know if Napa or O'Reilly has t bolt clamps, I have some on order but they won't be here til Monday.
sonofthehill is offline  
Old 07-11-2015, 03:09 PM
  #634  
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Texas
Posts: 1,147
Total Cats: 51
Default




Needs more girth. (Edited from my phone) You want the port to be wider almost up the walls and aligned with the hole. Then it needs to taper deeper as it gets closer to the hole. You should have the thickness a little thicker than a nickel at the hole. Also don't forget to take a sanding wheel and sand it with 120 to make it smooth or else you increase the likelyhood of cracks

The reason your overheating is two reasons. 1 you need a better aluminum radiator and 2 you need to duct it well then use the lisle no spill funnel to burp the system. The lisle funnel seriously is a must have.
Attached Thumbnails MKTurbo NA/NB Turbo Setups-80-image_e78263e4f149dd6c9d6b8a756d53ca42a2a1d11c.jpg  
ScottyP3821 is offline  
Old 07-11-2015, 07:21 PM
  #635  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

Thanks Scotty!
Will do more porting soon, picked up a no spill funnel.
My IC couplers blew off so definitely some major leakage, Napa doesn't have t bolt clamps :(
sonofthehill is offline  
Old 07-12-2015, 09:03 PM
  #636  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

I can idle cool again, thanks again Scotty for the no spill funnel suggestion. Got some clamps that work for now and it is pretty fast.
I am creeping up to 10.5psi by about 5200rpm so I have not pushed past there yet. Clearly I need to do more porting soon, just like you guys said.
Overall I am a very happy customer so far. We will see how my turbo holds up, if it fails I will buy one of the .42 a/r cold side units for $200 and try it out.
sonofthehill is offline  
Old 07-12-2015, 11:19 PM
  #637  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default



Now making over 10.5psi running very well still a bit too rich but I am getting there.
This thing pulls like hell.

Here is a 4th gear spool pull, still referencing my waste gate from the compressor housing.


Attached Thumbnails MKTurbo NA/NB Turbo Setups-80-undefined_5980ec693e2eff2fae4185cb8a3b46b768626a07.png   MKTurbo NA/NB Turbo Setups-80-undefined_e54645d5417ea645fa15810639a07e5c761fb2ba.png  
sonofthehill is offline  
Old 07-13-2015, 08:06 AM
  #638  
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Texas
Posts: 1,147
Total Cats: 51
Default

Where it spools up to 7psi then slowly goes up to 10.5 is boost creep. This will be more noticeable as you increase boost and when you add closed loop ebc. needs more porting. You want to port till it spools up to 7-8psi then either slowly tapers down or holds flat.
ScottyP3821 is offline  
Old 07-13-2015, 11:33 AM
  #639  
Moderator
iTrader: (12)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 17,620
Total Cats: 2,011
Default

Boost creep is actually less noticeable when you run more boost. If EBC is set at 10.5 you would never experience creep.
sixshooter is offline  
Old 07-13-2015, 12:00 PM
  #640  
Elite Member
iTrader: (1)
 
Join Date: Apr 2014
Location: SF Bay Area, CA
Posts: 2,363
Total Cats: 249
Default

Honestly, I was hoping to make about 12psi. If I reference post intercooler and run an mbc, I would probably get there a lot sooner.
I plan to port some more soon though.
sonofthehill is offline  

Thread Tools
Search this Thread
Quick Reply: MKTurbo NA/NB Turbo Setups


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.