Miata Turbo Forum - Boost cars, acquire cats.

Miata Turbo Forum - Boost cars, acquire cats. (https://www.miataturbo.net/)
-   Prefabbed Turbo Kits (https://www.miataturbo.net/prefabbed-turbo-kits-3/)
-   -   cruise control (https://www.miataturbo.net/prefabbed-turbo-kits-3/cruise-control-4072/)

BrokeEnthusiast 07-23-2006 09:13 PM

cruise control
 
well i put my kit on yesterday and I hit a snag, my cruise control is in the way of my intake piping that goes to the MAF, do i have to remove the cruise control for this kit to work? I dont see any other way around it, need an answer quick so i can go drive :)

BrokeEnthusiast 07-23-2006 09:18 PM

by the way my enthuza exhaust will be here wed. so Im going to be driving open DP hahaha

flashlegs 07-23-2006 09:33 PM

Is the cruise kit just a stock one from another Miata? I have cruise on my car and I had to take off one of the bolts that hold it on and twist it out of the way of the pipes. I think I have some underhood pics in the members rides part of the forum. Might help.

BrokeEnthusiast 07-23-2006 09:37 PM

please post the pictures, its the cruise control that came on the car stock

BrokeEnthusiast 07-23-2006 09:41 PM

well it looks like you got it to fit right behind the headlight very well, im gonna give it another shot

that7guy 07-23-2006 10:19 PM

Mine fit with the stock cc fine. Since then i have taken it out. Do you really need it? heres an old picture if you still need help:

BrokeEnthusiast 07-23-2006 11:28 PM

I dont really need it, I got it to go into place but its line runs right past the exhaust manifold, so If it doesnt melt then I guess its gonna be okay. I guess I will take it out when I get my IC only because I will be moving some more things around and all I want to do right now is break the turbo in

92mazdarati 07-23-2006 11:59 PM

I didn't have problems getting my greddy kit to fit w/ the cruise on my 92 miata, however when I tried to run the cruise the car would just keep on accelerating. It worked fine before I installed the turbo, but I was on the interstate a few days after I put my turbo in and I tried the cruise. It accelarated as normal to get back to the speed I was going when I first activated it, but then it kept accelerating. I put the clutch in and of course it just kept bouncing off the rev limiter. I think that it has something to do with there being boost where ther is normally vacuum and it tripped something in the cruise. I had to disconnect the vacuum line from the cruise control unit in order for it to stop accelerating. Otherwise it just keeps bouncing off the rev limiter everytime I start my car after I have tried to use the cruise

jayc72 07-24-2006 01:46 AM

Putting a check valve in the vacuum line to the CC actuator might help. Also the cruise should kick off when you put in the clutch. Replace the clutch switch, if you are having trouble with idle dip or stalling this will also help.

You should never be able to enter boost with the CC on, so it should work normally (with out the check valve).

Sounds like your actuator is FUBAR, or something is stuck.

ruger988 07-25-2006 03:12 AM

Quick notes on removing CC? instaled my greddy kit today andit's just kinda layng there outta the way for now until i rip it out tomorrow!!!

Jefe 07-25-2006 02:20 PM

Quote:

Originally Posted by jayc72
You should never be able to enter boost with the CC on, so it should work normally (with out the check valve).

W/ the CC on, the car should still enter boost.

jayc72 07-25-2006 02:36 PM

Maybe I wasn't clear what I meant. While USING the CC you wouldn't likely get into boost since the throttle wouldn't open enough. Since I don't have mine on the car any more I can't confirm that, but that was my understanding.

I know on my cruise using the accelerate toggle on the steering column it would accelerate VERY slowly.

Philip 07-25-2006 03:16 PM

Quote:

Originally Posted by Jefe
W/ the CC on, the car should still enter boost.

Mine never would, even with a check valve it would pull it right up to 0 PSI and then stop.

BrokeEnthusiast 07-27-2006 06:45 PM

ok well i am going to remove it this weekend, do i just cut the cable and pull it out, and plug the vaccume line or what?

Philip 07-27-2006 06:46 PM

you can take the cable out in tact, it just unclips from the gas pedal and pulls through the firewall. Probably worth a few bucks to someone with a melted cable

BrokeEnthusiast 07-27-2006 07:28 PM

i heard that you need to swap pedals after you do this is that true?

Snowsurfer03 07-27-2006 08:02 PM

I still have my CC and everything fits and works fine. It still enters boost with CC on. Goodluck.

brgracer 07-27-2006 08:12 PM

Quote:

Originally Posted by BrokeEnthusiast
i heard that you need to swap pedals after you do this is that true?

Not true. I removed my CC intact and sold it on fleabay for ~$100 so I'd listen to Phillip about removing it whole instead of just cutting and removing. Never switched pedals and never had any issues, even with bending the pedal toward the brake for better heel/toe access. YMMV.

BrokeEnthusiast 07-28-2006 02:07 PM

sweet, i need cash so I am going to sell it on ebay when i take it out


All times are GMT -4. The time now is 12:29 AM.