Idle miss and rough start after turbo install - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

DIY Turbo Discussion greddy on a 1.8? homebrew kit?

LinkBack Thread Tools
Old 10-21-2011, 11:16 PM   #1
Thread Starter
Join Date: Nov 2004
Location: troy michigan
Posts: 17
Total Cats: 0
Default Idle miss and rough start after turbo install

So what i got is like an ebay godspeed kit. 20g mitsu turbo fmic fpr and a walbro pump at like 7 psi. When i was done i started it and let it idle. Ran perfect. I finished I then did all the vacuum lines and the fpr and a walbro pump. Still started easy and ran good. Did a few test pulls to get the boost and timing right i was pretty close, then it started idling shitty and doesnt want to start. Ive checked all charge piping 5 times. Then I replaced the wires gapped the plugs at .032. No change. Im thinking maybe the o2 sensor or maybe a coolant temp or something. It runs great under load and boosting, and its pretty quick but once it comes down to idle it starts missing, a random feeling miss not a dead cylinder. Im gona go through the motions tomorrow at work and test some sensors and even compression test it(even though i just did it before putting on the turbo) and spark test.

So I was just wondering if anyone can diagnose my car over the cpu cause im tired and frustrated.

ps it does run and drive as is just starts hard and idles like crap
redrockkkit is offline   Reply With Quote
Old 10-22-2011, 12:03 AM   #2
Elite Member
iTrader: (7)
Join Date: Jan 2007
Location: Renton Washington
Posts: 1,742
Total Cats: 3

Sounds like vacuum leak.
SKMetalworks is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
00/99 IAC into 92 wiring harness AdoboMiata MEGAsquirt 4 09-22-2015 02:32 AM
Obligatory "N00B" post! D_Breezy Meet and Greet 5 09-08-2015 05:37 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 08:30 PM
Help Rough Idle Backwoodsballer General Miata Chat 0 09-04-2015 06:39 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:30 AM.