Low Vacuum and Rich Idle - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

DIY Turbo Discussion greddy on a 1.8? homebrew kit?

LinkBack Thread Tools
Old 08-28-2014, 08:56 PM   #1
Thread Starter
Join Date: Sep 2013
Location: Denver
Posts: 12
Total Cats: 0
Default Low Vacuum and Rich Idle

Currently at Idle I am seeing -9 vacuum and idle search. Once warm the idle search stops and my AFR's at idle are 10-10.1 rich. Low vacuum continues. Runs 5psi boost fine with good AFR's. Rich at the top RPM Range (5-6k).

Turbo Setup:
5 pounds of boost
EMB piggy back
Maf still connected
Walboro pump
Stock injectors
COPS setup
External Wastegate w/ TIAL BOV
PCV removed/vented and gasket cover to air, intake side plugged (Don't know why)
Intake at turbo/filter plugged, gasket cover to air (Again don't know)

Things tried:
Hooking pcv valve and turbo side intake back up to gasket cover (no change)
Checked over and over for vacuum leaks (carb cleaner, checked connections)
Cleaned MAF

Things haven't done:
Checked injectors for leak/seal (took injectors out and cleaned previously)
Installed a Megasquirt
Replaced stock o2/ wideband o2
Bypassing FPR

I am looking to get the Vacuum in line and understand or fix the rich idle. Seems like they could be related but may be way off base. Any help would be much appreciated. I was not the original engineer of this turbo setup. Thanks in advance.

Last edited by Test Subject; 09-01-2014 at 09:53 PM. Reason: Updating info
Test Subject is offline   Reply With Quote
Old 09-21-2014, 11:48 AM   #2
Junior Member
Join Date: Sep 2013
Location: Denver, CO
Posts: 76
Total Cats: -9

lexintexan is offline   Reply With Quote
Old 09-21-2014, 02:04 PM   #3
iTrader: (4)
FAB's Avatar
Join Date: Apr 2013
Posts: 917
Total Cats: 407

Your off the chart AFR is not helping. Do you not have control over your fuel at idle?

-Have you done a simple compression test?
-Have you simply tried pinching vacuum reference lines? BOV, Wastegate, FPR, Brake Booster
-Have you checked your timing? A tooth off will cause this. I see it all the time when someone thinks they have their timing set properly only to post a picture and it's off. The BP motors are a bit tricky if you aren't looking at it just right.
FAB is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 09:30 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 02:44 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 06:40 AM
WTB 90-97 miata low profile headlight kit DonPlatt WTB 0 09-25-2015 02:57 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:21 AM.