Wastegate not opening =( - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

DIY Turbo Discussion greddy on a 1.8? homebrew kit?

LinkBack Thread Tools
Old 07-04-2009, 03:18 PM   #1
Elite Member
Thread Starter
iTrader: (7)
Join Date: Jan 2007
Location: Renton Washington
Posts: 1,742
Total Cats: 3
Default Wastegate not opening =(

I have been slowly getting my car ready to be tuned professionally and my latest bit was re-routing lots of hoses and wires. Anyway. After i did this i went for a drive and took a quick look at my gauge and saw 20 PSI!! After a few experiements i found out that the wastegate functions normally.

My second experiement took the hose off from the tee between the turbo nipple/wastegate and put the manifold line there. Alas my wastegate is holding at psi. But i have no BoV (compressor surge blows). Its either one of two things.

The turbo nipple is blocked or giving an innaccurate amount of psi


My BOV is leaking super freakin bad at the port. In low vaccume the BOV does leak but in boost it holds fine.

Thoughts? Ideas? Advice?
SKMetalworks is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 17 10-02-2015 09:28 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 06:40 AM
WTB; na6 Miata things (Canada) Jared Rowe WTB 0 09-23-2015 11:57 AM
Innovate LC-2 Wideband O2 Sensor w8lifter21 Miata parts for sale/trade 0 09-14-2015 11:30 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:39 PM.