90 miata help - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 09-27-2011, 01:40 PM   #1
Thread Starter
Join Date: Sep 2011
Posts: 4
Total Cats: 0
Default 90 miata help

new sorry if in wrong place my miata stumbles when you first start it any time then when it gets to temp it acts just fine so far i have replaced map sensor isc plugs wires fuel pump and filter don't know what is going on new timing belt checked spark i don't know what else to look at. i need to figure this out i was about to put on a turbo since the outside of the car was almost done please any help would be nice
josbtlr is offline   Reply With Quote
Old 09-28-2011, 10:28 PM   #2
Elite Member
iTrader: (4)
MartinezA92's Avatar
Join Date: Aug 2009
Location: Sunnyvale, CA
Posts: 1,572
Total Cats: 9

Pump your brakes dude, you've given practically no information. List what you use for engine management.

If this is stock I'd say its your coolant temp sensor at the back of the head.
MartinezA92 is offline   Reply With Quote
Old 09-29-2011, 08:18 PM   #3
Elite Member
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12

Replace the coolant temperature sensor at the back of the motor.
dustinb is offline   Reply With Quote
Old 09-30-2011, 11:28 AM   #4
Elite Member
iTrader: (3)
Join Date: Mar 2008
Location: Granbury, TX
Posts: 5,765
Total Cats: 544

Jeez. Talk about an unreadable post. Capitalization. Punctuation. It works.

Go here to understand how the 1.6 idle works: http://www.miata.net/garage/isc.html

If it won't idle when cold, your Air Valve could be stuck closed. Can't even tell if that's your problem from your post. You should try diagnosis instead of parts replacement, BTW.

Note that I was polite enought to capitalize and punctuate. You owe me.
hornetball is offline   Reply With Quote
Old 09-30-2011, 12:14 PM   #5
Elite Member
iTrader: (12)
Join Date: Nov 2009
Location: Harpers Ferry WV
Posts: 1,521
Total Cats: 20

I vote temp sensor on the back of the head. Had the same problem in my car.
Sean is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 07:58 AM
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 06:13 AM
New M62 Miata owner Pist0n Meet and Greet 4 10-01-2015 08:18 PM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 06:40 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:52 AM.