Code P0507, 02 causing this? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 07-30-2009, 08:54 PM   #1
Check out my part outs.
Thread Starter
iTrader: (26)
thirdgen's Avatar
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,455
Total Cats: 115
Default Code P0507, 02 causing this?

So I had my MS (parallel unit) hooked up for over a year, and a few weeks ago the car started to idle high (1300-1500 RPM.) I got the code P0507 which is "Idle control system RPM high." So I was thinking this was my IAC. I removed my IAC and cleaned it, and I even put voltage to it, and watched it move.
Now my car is back to running on the stock ECU...ocassionally my idle goes high like it did, but otherwise it runs right around 1,000 RPM. I noticed that I never get a P0171 (System too lean) or P0172 (system too rich) code like I had been getting in the past. Could it be that my stock O2 sensor crapped out and perhaps the stock ECU is compensating by actuating the IAC?
thirdgen is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 10:59 PM
Help multi issues here! ReallyRottenTurbo MEGAsquirt 4 09-22-2015 12:49 PM
In what world... curly MEGAsquirt 11 09-22-2015 11:54 AM
Microsoft Edge browser & MT.NET bahurd Front Desk 0 09-21-2015 08:45 AM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 07:42 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:12 AM.