I hate the 2001 cam sensor - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 11-12-2006, 04:46 PM   #1
2 Props,3 Dildos,& 1 Cat
Thread Starter
iTrader: (8)
y8s's Avatar
Join Date: Jun 2005
Location: Fake Virginia
Posts: 18,753
Total Cats: 318
Default I hate the 2001 cam sensor

This part seems to be in the way of everything I do. It sits on top the intake cam near the back of the motor and has a connector sticking up out of it. The position and design of it make it WAY too easy to snap in half under the connector boss. That breaks the electrical connection and bam code P1345 and the car wont start.

I spent the last hour hacking it open and soldering in some jumper wires. Now it's ugly but it works again and didn't cost $75. Started the car, cleared the code, bam.


But really, I wanted to celebrate the clutch job working out. Needs a little break-in but it's in and adjusted. Woohoo!
y8s is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 52 08-28-2016 04:18 AM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 01:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 12:15 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:53 AM.