Mishimoto Radiator, 99-05, poor fitment, what to do? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 10-17-2011, 03:22 AM   #1
Junior Member
Thread Starter
iTrader: (5)
Join Date: Oct 2010
Location: Queens, NYC
Posts: 201
Total Cats: 3
Default Mishimoto Radiator, 99-05, poor fitment, what to do?

I purchased a mishimoto radiator + radiator hoses, and went to install them all today, ran into a few issues, not sure if I should work around them, and fix them. Or should I try to return/exchange and start over with a radiator from another manufacturer?

1-lower posts on rad doesn't drop into the stock bracket holes. I could bore out the holes till it does I guess.

2-one of the holes meant to screw the fan shroud onto the radiator had a stud broken off in it, on a brand new, sealed radiator, with retail packaging! I tried to get it out with a bolt extractor and broke that off in there too. Could just ignore it, the remaining screws hold the fan shroud in place well enough.

3-stock fan shroud doesn't leave enough clearance for my cold pipe on tb side. I have a blow-through maf, and there's now not enough space for maf there. I am going to be squirted soon, but I wanted to retain stock ecu/maf for that once a year thing. I could buy slim fans, but should I?

4-the lower radiator hose seems impossible to install unless I pull my msm turbo. Somehow, that doesn't seem worth the effort. I can't return just that one, its a set with the upper hose. What do I do with it?

5-Some of the fins on the radiator were bent dropping it in. I wonder if I'll have trouble trying to get a refund/exchange because of that. My car is un-driveable atm, I didn't want to pull the rad out in fear of bending more fins.

What would you guys do? Work around the problems, and diy till everything works as it should? Or try to give it back and get something else?
bigx5murf is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 143 05-21-2016 05:48 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 11:04 AM
WTB Stock NB Pistons pdexta WTB 0 09-28-2015 11:18 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 06:40 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:25 PM.