Water Temp Sensor Failure? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 04-26-2010, 05:30 AM   #1
AFM Crusader
Thread Starter
iTrader: (18)
olderguy's Avatar
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,247
Total Cats: 64
Default Water Temp Sensor Failure?

Has anyone had the water temperature sensor fail on a 1.8? The symptoms I am seeing on a friends car (stock 1996) are overheating because the fans won't come on and rich running. OBDII shows only an EGR flow problem. Fan relay OK, wiring OK.

Has anyone seen this failure mode of the sensor before I go to the trouble of replacing it for him?
olderguy is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 01:11 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 11:04 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:17 AM.