Hydra 2.17 randomly loses power- shuts car off - Page 4 - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

LinkBack Thread Tools Search this Thread
Old 02-03-2015, 03:36 PM   #61
Former Vendor
Join Date: Feb 2008
Posts: 128
Total Cats: 2

I've seen many cars, including one of my old ones, where main relays keep cooking. I figured out it's not really fixed until you also pull the fuse box up & find the most-likely burnt wires on the bottom side feeding the relay. Replacing the burnt ends plus a new main relay usually solves the problem.

1990-2002 cars use a traditional ignition-switch powered main relay setup. 2003-05 cars however use a different setup where the ignition switch controls the ECU which controls the main relay switching.

Mike, you should take advantage of the current 2.7 upgrade sale!
usd2bfst is offline   Reply With Quote
Old 02-03-2015, 04:08 PM   #62
Cpt. Slow
iTrader: (24)
curly's Avatar
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 11,618
Total Cats: 463

Mspro bro!
curly is offline   Reply With Quote
Old 02-04-2015, 04:17 PM   #63
Junior Member
iTrader: (2)
Join Date: Jan 2012
Posts: 156
Total Cats: 4

The 80a JE16 relay has been holding up so far. Did a nice tuning session today that was 3-4 times longer than it would previously take to kill the old relays.

I will report back if it fails, but so far it seems to have fixed the issue.
Ian is offline   Reply With Quote
Old 02-16-2015, 07:46 PM   #64
Junior Member
iTrader: (2)
Join Date: Jan 2012
Posts: 156
Total Cats: 4

JE16 relay failed today after a 3 hour drive. Need to start looking through the electrical system now. :sigh:
Ian is offline   Reply With Quote
Old 04-17-2015, 08:20 AM   #65
Elite Member
Thread Starter
iTrader: (12)
Join Date: Sep 2007
Location: Portland, Oregon.
Posts: 6,841
Total Cats: 63

Figure since I'm doing some searching and seeing this thread, I can update.

Car has had 2.7 for awhile and has not had the power-loss issue in quite sometime. Not terribly long ago, the damn main relay offed itself, but I know what to look for with that now. I still don't know what was causing the intermittent power cuts way back then. IIRC it did stop when I upgraded to 2.7
Doppelgänger is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 08:36 PM
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 01:34 PM
Squiblez 1996 Montego blue Squiblez Build Threads 2 09-22-2015 10:17 AM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 07:42 PM
WTB parts for HPDE car Voltwings WTB 5 09-11-2015 08:23 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:28 PM.