rebuild problems someone please help me - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market TrackSpeed

LinkBack Thread Tools
Old 09-14-2007, 04:17 AM   #1
I'm Miserable!
Thread Starter
Join Date: Jul 2006
Location: sandiego, CA
Posts: 332
Total Cats: 0
Default rebuild problems someone please help me

ok ive rebuilt my turbo before had no problems. well so this time i pull everything apart i clean it all with brake cleaner get it all cleaned up then install all the new parts in it and go to tighten down the nut on the end to hold the blades to the shaft and when i tighten any tighter then hand tight the thing wont spin at all? wtf anyone have any ideas? ive tried putting back in the crap stuff same thing am i doing something wrong i am doing everything the same way i did before.i dont get it.
drftem is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 01:42 PM
Squiblez 1996 Montego blue Squiblez Build Threads 2 09-22-2015 10:17 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:17 PM.