AEM
Sponsored by:
Sponsored by:

aem fic cam/crank signal on 1.6 1993

 
Old 03-28-2018, 06:02 PM
  #1  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default aem fic cam/crank signal on 1.6 1993

ive wired in the fic and car wouldnt start. if i dont intercept the cam signal wire, it starts but wont idle. i tried the signal wire on 2G and 2E pins. some searching shows others have the same problem but couldnt find a resolution...

using aem install guide and this chart for ecu wiring https://www.miata.net/garage/ECU_Pin-Out.png

i did not wire the tps, as its a on off type. injector 1 and 2 on fic are wired to 2U and 2V. maf signal is showing up on the fic software. all settings in software are running off maf.

anyone know?
Leepi Leep is offline  
Old 03-28-2018, 06:43 PM
  #2  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

been a while since I worked with FIC, but this car ran well ... better than some of the MS cars I have driven. Hope you can find something useful.
Attached Files
File Type: pdf
MIATA_REV5.pdf (148.6 KB, 20 views)
Ted75zcar is offline  
Old 03-28-2018, 08:31 PM
  #3  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

Just looked at that SCH, I don't think that one was for an FIC, probably one of the first MS schematics. This one looks better.
Attached Files
File Type: pdf
MIATA_REV2.pdf (148.2 KB, 29 views)
Ted75zcar is offline  
Old 03-28-2018, 08:56 PM
  #4  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default

hi Ted, thanks for the diagrams, the first one is for the fic i believe.

the diag shows intercept on 2 wires to crank and cam signal to the fic, as well as all 4 injectors wired instead of the batch thats said to be on the na6 ecu..

ill print it all out at work tommorrow so i dont lose my vision on this monitor


i will tackle it again , really appreciate these
Leepi Leep is offline  
Old 03-28-2018, 09:11 PM
  #5  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

no problem

I am fairly certain you want the REV2 version REV5 breaks the cam and injector connections at the terminal blocks (TB1 and TB2). The 1-3 and 2-4 injectors are shorted together on the chassis harness/ECU side of TB1. I don't remeber why I did it this way, I may have been provisioning for sequential, or increasing the current capability of the FIC by running 2 channels in parallel.

Sorry about the density on these things, the Eagle freeware version I was using only allowed 1 sheet.
Ted75zcar is offline  
Old 03-28-2018, 10:13 PM
  #6  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default

couldnt wait..haha

just reviewed rev2

seems i have the crk and cam signals mixed

also

inj 1_3 is on both pin 1 c29 and pin 12 c30, and splice after tb1 then to 2U at ecu

does this mean i should wire both pins to 2U?
Leepi Leep is offline  
Old 03-28-2018, 10:20 PM
  #7  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

Yeah, I just looked at the FIC spec, the injector outputs are limited to 1.7A. I suspect that was too marginal for my liking with 2 injectors, so I decided to run 2 channels in parallel.

simply put, yes.
Ted75zcar is offline  
Old 03-29-2018, 08:11 PM
  #8  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default

im pretty certain my wiring is correct, ive tapped power off pin 1a on the other ecu connector

here is an excel i made of all my connections...

<!--td {border: 1px solid #ccc;}br {mso-data-placement:same-cell;}-->24 pinAFM_WPR_CSMAF_IN+DK BLUE142o csAFM_WPR_ECUMAF_OUTBLACK152o ecuCRK_ANG_G_CSCAM1_HALIYELLOW82g csINJ_2_4_CSINJ_4_OUTDK BLUE192v csINJ_1_3_CSINJ_3_OUTDK BLUE202u csINJ_2_4_CSINJ_2_OUTDK BLUE212v csINJ_1_3_CSINJ_1_OUTDK BLUE222u csINJ_1_3_ECUINJ_3_INDK BLUE122u ecuINJ_2_4_ECUINJ_4_INDK BLUE242v ecu22pinINJ_1_3_ECUINJ_1_INDK BLUE12u ecuINJ_2_4_ECUINJ_2_INDK BLUE122v ecuCRK_ANG_G_ECUCAM1_HALOYELLOW32g ecuCRK_ANG_NE_ECUCRK_HALO142e ecuCRK_ANG_NE_CSCRK_HALI72e csGNDPWR_GNDBLACK42a tapGNDPWR_GNDBLACK152b tapAGNDSIG_GNDBLACK52c tap12VSW_FICIGN_PWRRED161a tap

can you spot anything incorrect? it wont start, after a few seconds crank, pause then crank itll fire for a few rpms, so it is getting gas and spark... tables are all zerod out.

not sure if theres some specific firmware or steps to enable 4 cylinder mode instead of 6? ive read the aem manual but maybe im overlooking something....
Leepi Leep is offline  
Old 03-29-2018, 08:12 PM
  #9  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default



dont think it uploaded correctly , heres a snippet
Leepi Leep is offline  
Old 03-29-2018, 09:57 PM
  #10  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

Honestly man, it has been long enough that I don't even have a computer with the FIC software installed anymore.

One thing I think I remember is that if you intercept the MAF, you need to set it to percent with zeros everywhere to start out with. you can then log the voltages and switch to voltage out and eliminate the AFM.

Have you logged anything yet? That might tell you what is going on.
Ted75zcar is offline  
Old 04-07-2018, 04:09 PM
  #11  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default

hi Ted or anyone else that may have input,

Im having no luck with the crank and cam signals. Without them connected (straight to factory ecu) the car will start idle fine. I have read other posts saying addition of resister to filter out the signal might be required. Im not sure if its worthwhile to attempt this or give up on the fic and source a megasquirt. The fic seemed so much simpler as it does all I need, and standalones usually come with their own set of headaches.

Thanks
Leepi Leep is offline  
Old 04-09-2018, 08:02 PM
  #12  
Tweaking Enginerd
iTrader: (2)
 
Join Date: Mar 2013
Location: Boulder, CO
Posts: 983
Total Cats: 119
Default

Does the FIC report rpm while cranking? I dont remember how you configure the FIC for the cam/crank signals. Do you have that setup properly?
Ted75zcar is offline  
Old 04-10-2018, 04:41 PM
  #13  
Junior Member
iTrader: (1)
 
Join Date: Aug 2015
Location: Lakeland Florida 33805
Posts: 78
Total Cats: 2
Default

I have the FIC6 in my 2002. Is currently wired to intercept the MAF signal. With mine all zero'd, it wouldn't run. I can't remember what my MAF settings are, but they're not zero's. When I get a chance I'll hook up the laptop and see what it's set to. My engine is not boosted yet either, and running stock injectors. I only installed the FIC to get used to it before I started to change big parts.
alsmedic is offline  
Old 04-11-2018, 09:46 AM
  #14  
Newb
Thread Starter
 
Join Date: Jun 2017
Location: north nj
Posts: 36
Total Cats: 2
Default

it does report rpms and log is showing everything except tps and o2, since those arent wired in.

im not sure if aem has a "setting" for say for which signal to use. i just flashed the z110 firmware for batchfire.

im going to give the oscilliscope / resistor mod a shot, seems its a universal issue across platforms, and dependent on each individual cam/crank sensor. i snagged a deal for one on amazon for 30 bucks so its not a complete loss
Leepi Leep is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
coma
MEGAsquirt
35
05-12-2016 01:45 PM
Halcyon
MEGAsquirt
16
04-22-2012 03:36 PM
JasonC SBB
AEM
25
08-25-2011 11:54 PM
Pitlab77
Insert BS here
1
05-31-2008 08:39 AM
Pitlab77
General Miata Chat
3
07-09-2007 07:00 PM


Thread Tools
Search this Thread
Quick Reply: aem fic cam/crank signal on 1.6 1993


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.