Daily Driver Budget Build - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 11-16-2013, 12:16 AM   #21
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

Just an update, recently swapped in a new T25 as the old one had some impeller damage. Can't notice if it's faster or anything but it's definitely quieter. I also got some Stage 8 locking hardware which I'm liking very much. I also sealed up my valvecover with sealant and am running Rotella T6 now, haven't sprung any new leaks yet either.

I thought I melted my LC-1 but it was just a bad ground, I wasted some money but now I have an LC-2. I also mounted my boost gauge properly but am pretty pissed because it's an amber-orange crappy light instead of red so I may swap it for a red LED.

I also fixed a few niggling problems I've been ignoring because I've got to pass emissions this month. I have an exhaust leak from a gap in the weld on my log manifold and I'm hoping I can get a shop to weld it up in-place. That's the only problem with my turbo kit so far.

Once I pass emissions my big injectors will go in and I'll turn up the boost and get it on a dyno.
vitamin j is offline   Reply With Quote
Old 11-19-2013, 07:37 PM   #22
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

I did some Virtual Dyno pulls today and got some good results. Uncorrected it calculated 155hp/143lbft and SAE corrected it gave 180hp/165lbft. Pretty good results IMO. I want 200whp corrected whp so my target isn't far off. Lots of room to go from 6psi.

e: Just passed about 4200 miles on the turbo kit, 190k on the chassis, and 190k on the motor that had only a bench hone and re-ringed, used, '04 pistons/rods installed at 100k. Reused all original bearings except for 2 crankbearings. ****** love BPs.
Attached Thumbnails
Daily Driver Budget Build-miataturbo-virtual-dyno-6psi-uncorrected.jpg   Daily Driver Budget Build-miataturbo-virtual-dyno-6psi-corrected.jpg  

Last edited by vitamin j; 11-19-2013 at 08:10 PM.
vitamin j is offline   Reply With Quote
Old 11-20-2013, 01:16 AM
tylerart
This message has been deleted by sixshooter. Reason: junk post
Old 11-20-2013, 11:15 AM   #23
Senior Member
 
Join Date: Sep 2013
Posts: 903
Total Cats: 59
Default

Where are you putting the speed holes? Have you been to the track?
Dunning Kruger Affect is offline   Reply With Quote
Old 11-20-2013, 11:44 AM   #24
Senior Member
iTrader: (6)
 
Join Date: Sep 2007
Posts: 1,085
Total Cats: 30
Default

It's obvious who has been to the track and who hasn't
albumleaf is offline   Reply With Quote
Old 11-21-2013, 01:18 AM   #25
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

yawn
vitamin j is offline   Reply With Quote
Old 11-21-2013, 01:18 AM   #26
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

Put in my 550s and turned the boost up to 10psi. Holy ****, gonna lose my license... again.
vitamin j is offline   Reply With Quote
Old 11-21-2013, 08:37 PM   #27
Junior Member
 
Join Date: Sep 2013
Location: Denver, CO
Posts: 76
Total Cats: -9
Default

Has your radiator been working so far? Debating on what to do for cooling when I eventually turbo.
lexintexan is offline   Reply With Quote
Old 11-21-2013, 08:54 PM   #28
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

Yeah I lucked out and only had to drive a few weeks using the AC in hot weather. After doing more ducting though it got to the point where it would never go over more than about 205 degrees with the AC on, even while idling. I have an M-tuned reroute but I decided to hold off installing it til the spring and I'll be getting a new radiator about that time too. Definitely won't need it this winter.

Great weather today for driving a Miata isn't it?
vitamin j is offline   Reply With Quote
Old 11-21-2013, 08:57 PM   #29
Junior Member
 
Join Date: Sep 2013
Location: Denver, CO
Posts: 76
Total Cats: -9
Default

Haha even better weather to pull it into the garage and get ready for a project!
lexintexan is offline   Reply With Quote
Old 11-21-2013, 09:06 PM   #30
Junior Member
 
Join Date: Sep 2013
Location: Denver, CO
Posts: 76
Total Cats: -9
Default

Oh, was also wondering if you had much of a problem with Denver's emissions testing? Are you using the drive by testers or go to a facility?
lexintexan is offline   Reply With Quote
Old 11-21-2013, 09:48 PM   #31
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

I actually just passed emissions the other day using my MS1 in parallel with the OEM ecu. I detailed it here:
https://www.miataturbo.net/megasquir...8/#post1074776
vitamin j is offline   Reply With Quote
Old 03-01-2014, 08:54 PM   #32
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

My car was down for a month and a half due to some weird electrical problems but it's back up and running now. My MS1 died so I've upgraded to MS3x I scored on here with some goodies like a knock sensor and bluetooth.

While my car was down and I was jealous of my gf's Mazda2's gauges, I did the red LED mod for my gauge cluster.

I also made an oil catch can out of a medicine bottle.
Attached Thumbnails
Daily Driver Budget Build-imag0069.jpg   Daily Driver Budget Build-imag0072.jpg  
vitamin j is offline   Reply With Quote
Old 03-08-2014, 11:50 PM   #33
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

Birthday cake!

Attached Thumbnails
Daily Driver Budget Build-imag0104.jpg  
vitamin j is offline   Reply With Quote
Old 03-08-2014, 11:51 PM   #34
Elite Member
iTrader: (13)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,702
Total Cats: 237
Default

LOL dude that is so awesome. +propped
Fireindc is offline   Reply With Quote
Old 03-09-2014, 10:01 AM   #35
Junior Member
 
Join Date: Feb 2012
Location: Atlanta, Ga
Posts: 265
Total Cats: 36
Default

Just reading this. That orig cost ($1400ish) is amazing. Once you factor in the clutch and ms3 your at what, $2600? Can't be done legit for less.
carnut169 is offline   Reply With Quote
Old 03-09-2014, 09:01 PM   #36
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

Haha thanks Fire, it was damn tasty too!

Yeah the goal was to do it as cheap as possible. Honestly I should have just spent $800 on a mani and downpipe instead of building my own but oh well, upgrade path.
vitamin j is offline   Reply With Quote
Old 03-10-2014, 04:24 PM   #37
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

I got a weird issue with overrun fuel cut on my MS3x. The TPS sensor is working fine, and I even bought a new one to test but the problem remains. Basically only when in overrun, coasting in gear, the TPS % will jump from 0% to 5-7% and sometimes to 10-15% which will make it add fuel and it jerks and bumps and it sucks. My overrun fuel cut always worked perfectly with my MS1 install. Any ideas?
vitamin j is offline   Reply With Quote
Old 03-18-2014, 11:40 PM   #38
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

Still hunting this electrical crazy, seemingly everywhere, problem with the electrics. The TPS issue is still unresolved. Fuel pump relay doesn't engage with ignition, running off the diagnostic box jump still, tried brand new relay = same issue.

AC doesn't work. I have a westfieldmx5-built MS3x according to the seller, but according to westfieldmx5 I have a brainiack-built MS3x...and I know better than to ask brain for help. Still snowing/70* and sunny so I have a few weeks/months to figure the AC problem out before Denver emulates Phoenix.

Returning 26mpg combined cycle. Less than the 30+mpg I was getting with the beater and 28mpg pre-turbo, but it's worth it when dusting 300Cs and every bro-truck in town.
vitamin j is offline   Reply With Quote
Old 04-21-2014, 01:59 PM   #39
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2009
Location: Morrison, CO
Posts: 470
Total Cats: 46
Default

My buddy chased me with his quad rotor and it made for some pretty cool footage:

vitamin j is offline   Reply With Quote
Old 04-21-2014, 02:00 PM   #40
Elite Member
iTrader: (13)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,702
Total Cats: 237
Default

Video fail! I'd like to see it, so fix it. Just put everything past the "=" in the youtube URL into the [YT] brackets.
Fireindc is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 07:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:00 PM.