Boost gone after 2.5" downpipe? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 04-13-2010, 03:03 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2010
Location: SF Bay Area
Posts: 142
Total Cats: 0
Thumbs down Boost gone after 2.5" downpipe?

I have a greddy with intercooler setup, so, I got a 2.5inch downpipe/exhaust done by 18psi a week ago (thanks again) After having the whole install, the boost jumped to 12psi on WOT (at this point it pulled like it should), so I tried to stay out of boost for the most part until my MS installation (getting it done tomorrow). Just today I start hearing a whining sound, so I WOT in first gear and it was at 3psi and 2nd gear @ 13psi, but no pull whatsoever. Is it the wastegate? Should I replace the greddy one? If so with which? Can it also be a leak?
caideN is offline   Reply With Quote
Old 04-13-2010, 05:09 PM   #2
I EAT CUM
iTrader: (6)
 
Join Date: Sep 2008
Location: Redneck, Texas
Posts: 1,218
Total Cats: -1
Default

What are you using as management if your MS isn't in?
Turbo_4 is offline   Reply With Quote
Old 04-13-2010, 05:32 PM   #3
Junior Member
iTrader: (1)
 
Join Date: May 2009
Posts: 120
Total Cats: 0
Default

im guessing, bipes for timing and such?
mekaw is offline   Reply With Quote
Old 04-13-2010, 06:27 PM   #4
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,653
Total Cats: 1,559
Default

Quote:
Originally Posted by Turbo_4 View Post
What are you using as management if your MS isn't in?
Are you kidding? It is right there in his signature...


How can anybody help him without all the facts? Oh, yeah, they can't.


Help us help you.
sixshooter is offline   Reply With Quote
Old 04-13-2010, 07:20 PM   #5
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,173
Total Cats: 2,575
Default

its a greddy kit running rrfpr and I "think" retarded cas for timing. dunno for sure.

I'm guessing wga too, but you can easily check that by disconnecting it and CAREFULLY going into boost. Once you go past about 10psi let off immediately cause it will just keep rising.


Your intercooler piping looked REALLY bad too man, I would inspect that as well. Probably blew a coupler or one flew off.

Just my guess.

And you're welcome, glad you like it
18psi is offline   Reply With Quote
Old 04-13-2010, 07:40 PM   #6
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2010
Location: SF Bay Area
Posts: 142
Total Cats: 0
Default

yep, no management as of now just retard and fpr. It was holding boost fine a week before, just wondering what can be causing that weird *** 1st 3psi then 2nd 13psi ****
caideN is offline   Reply With Quote
Old 04-13-2010, 07:47 PM   #7
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2010
Location: SF Bay Area
Posts: 142
Total Cats: 0
Default

Quote:
Originally Posted by 18psi View Post
its a greddy kit running rrfpr and I "think" retarded cas for timing. dunno for sure.

I'm guessing wga too, but you can easily check that by disconnecting it and CAREFULLY going into boost. Once you go past about 10psi let off immediately cause it will just keep rising.


Your intercooler piping looked REALLY bad too man, I would inspect that as well. Probably blew a coupler or one flew off.

Just my guess.

And you're welcome, glad you like it
Yeah i thought it might have been a piping or coupler, but nope, looks fine. I'm going to turn the boost lower and see if it holds.
caideN is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:17 PM.