DIY Turbo Discussion greddy on a 1.8? homebrew kit?
Sponsored by:
Sponsored by:

Builds boost but no power! NEED HELP!!

 
Old 08-27-2018, 10:46 PM
  #1  
Newb
Thread Starter
 
Join Date: Aug 2018
Posts: 9
Total Cats: 0
Default Builds boost but no power! NEED HELP!!

Hows it going guys! i need some of your guys expert info! i have a 1993 miata na turbo 1.6l witha t25 turbo with cast manifold with cx racing intercooler piping kit. Also have ACT HD Performance clutch that is rated for about 450hp Also with a ACT street performance 13lbs flywheel. im having an issue with boost to power.

The clutch and flywheel were installed about a week ago and have put probably 300 miles on it to break it in and make them two friends. My boost gauge is reading solid 10 pounds of boost but i dont feel the power. At about 2-5 pounds i feel it pull but when i get above that it basically feels the motor just revs but doesnt pull. I dont think it could be the clutch slipping because its a new clutch but idk! thats why i need help! Could i be getting spark cut? To much fuel? afr is at about 10.8 when at full boost which is low which i need to fix. Could my BOV be stuck open?

ALL IN ALL im getting boost but no power to the wheels! please someone give me a direction to go so i can fix my car!! Thank You!
Conner Merchant is offline  
Old 08-27-2018, 10:54 PM
  #2  
Elite Member
 
Join Date: Apr 2010
Location: Newcastle, Australia
Posts: 2,827
Total Cats: 55
Default

It's a slipping clutch.

Someone probably forgot to wipe the wd40 off of the clutch or flywheel.

Dann
nitrodann is offline  
Old 08-27-2018, 10:57 PM
  #3  
Newb
Thread Starter
 
Join Date: Aug 2018
Posts: 9
Total Cats: 0
Default

Will the wd40 wear off over time?
Conner Merchant is offline  
Old 08-27-2018, 11:01 PM
  #4  
Elite Member
 
Join Date: Apr 2010
Location: Newcastle, Australia
Posts: 2,827
Total Cats: 55
Default

Id say the assembly will be glazed on the disk and metal parts and it probably needs a fresh disk and re machining.

Also check the pedal adjustment, it will slip if there is no free play because the clutch will be constantly partly depressed.

Dann
nitrodann is offline  
Old 08-27-2018, 11:17 PM
  #5  
Newb
Thread Starter
 
Join Date: Aug 2018
Posts: 9
Total Cats: 0
Default

So all in all check the adjustment on the clutch pedal if that doesnít work under the knife I go to replace and remachine?
Conner Merchant is offline  
Old 08-27-2018, 11:19 PM
  #6  
Elite Member
 
Join Date: Apr 2010
Location: Newcastle, Australia
Posts: 2,827
Total Cats: 55
Default

Id say so.

Source: replaced 50+ mx5 clutches.
nitrodann is offline  
Old 08-27-2018, 11:30 PM
  #7  
Newb
Thread Starter
 
Join Date: Aug 2018
Posts: 9
Total Cats: 0
Default

Thank you! Iíll keep this thread informed to help others!
Conner Merchant is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Chiburbian
Insert BS here
6
09-07-2016 10:59 PM
rhines
ECUs and Tuning
2
09-11-2014 06:10 PM
bogly
MEGAsquirt
16
12-03-2013 04:26 PM
itskrees
Engine Performance
4
06-06-2013 11:30 PM
buffon01
Build Threads
501
09-05-2010 06:15 PM


Thread Tools
Search this Thread
Quick Reply: Builds boost but no power! NEED HELP!!


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.