miata hits wall under boost - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 12-15-2013, 02:44 AM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default miata hits wall under boost

pulled my freshly built turbo miata out of garage and test drove it. fine tuned maps on my AEM FIC. Runs great at idle but as soon as it sees boost it bogs down and slows down.

GT2560 turbo
550cc inj
FMIC
10 psi wastegate
boomslang harness

it will build boost up to 6 psi and afr are 12.5 under boost.
gas in tank has sat in tank for two months without starting car.
running ngk R plugs one step colder than stock
timing is retarded 1 degree per pound of boost.
no boost leaks i can see or hear.
brand new O2 sensors
maf seems to be working.

any ideas on whats causing it to hit a wall under boost?
kman456 is offline   Reply With Quote
Old 12-15-2013, 02:52 AM   #2
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

btw its an 01 vvt
kman456 is offline   Reply With Quote
Old 12-15-2013, 03:27 AM   #3
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Whats the afr gauge say when it bogs down?
triple88a is offline   Reply With Quote
Old 12-15-2013, 03:35 AM   #4
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

12.5 AFR
kman456 is offline   Reply With Quote
Old 12-15-2013, 03:37 AM   #5
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

Mad clamp is set to 4.5v but have maf map dialed in
kman456 is offline   Reply With Quote
Old 12-15-2013, 03:42 AM   #6
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

12.5 is pretty lean especially since u're running a piggy back.
triple88a is offline   Reply With Quote
Old 12-15-2013, 03:51 AM   #7
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

Would that cause it to fall on its face at 1psi boost
kman456 is offline   Reply With Quote
Old 12-15-2013, 04:29 AM   #8
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

1 psi, no, ecu gotta be ******* around with the timing.
triple88a is offline   Reply With Quote
Old 12-15-2013, 04:46 AM   #9
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

I'll try to retard timing going into boost earlier
kman456 is offline   Reply With Quote
Old 12-15-2013, 04:53 AM   #10
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

The ecu, like you, is probably too retarded.
18psi is offline   Reply With Quote
Old 12-15-2013, 11:38 AM   #11
Senior Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 1,119
Total Cats: 33
Default

"theres a nasty hole in your fuel map, that's why you're unloading in third"
supercooper is offline   Reply With Quote
Old 12-15-2013, 11:59 AM   #12
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

Came to see a Miata literally hit a wall....

I am disappoint
BTMiata is offline   Reply With Quote
Old 12-15-2013, 02:17 PM   #13
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

What happened to camaraderie between car enthusiasts. I seriously need help on this. I know I didn't buy a MS but I have what I have. That's not gonna change. Even though I hate this site. Because people on here are so disrespectful. I know you guys know your stuff.

So please can someone point me in the right direction.
kman456 is offline   Reply With Quote
Old 12-15-2013, 02:24 PM   #14
Senior Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 1,119
Total Cats: 33
Default

Quote:
Originally Posted by kman456 View Post
pulled my freshly built turbo miata out of garage and test drove it. fine tuned maps on my AEM FIC. Runs great at idle but as soon as it sees boost it bogs down and slows down.

GT2560 turbo
550cc inj
FMIC
10 psi wastegate
boomslang harness

it will build boost up to 6 psi and afr are 12.5 under boost.
gas in tank has sat in tank for two months without starting car.
running ngk R plugs one step colder than stock
timing is retarded 1 degree per pound of boost.
no boost leaks i can see or hear.
brand new O2 sensors
maf seems to be working.

any ideas on whats causing it to hit a wall under boost?
Does it do it at operating temp? Ive experienced some Miatas that do that while cold, but they were all running stock ecu.
The 2 month old gas shouldnt affect it
The 1 step colder NGK plugs are good, but 2 steps colder than stock MIGHT be better.
Everything else seems legit.... BUT the "maf seems to be working." Part makes me wonder. You are running an Aftermarket Management system, and still have a MAF?
I would bet it is either the MAF, or your tune, or a combo of both

Do you have any Data logs of any kind? Can the AEM FIC do that?
supercooper is offline   Reply With Quote
Old 12-15-2013, 02:31 PM   #15
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

It boosted and pulled to 2 psi fine cold.( was still tunning so did little pulls into boost to watch AFR)

I bought a boomslang harness comes with maf wired in. Or I would of deleted it.

FIC can data log. I will do a boost pull and post it.
I have seen on forum guy had this happen because his MAF clamp was to low so stock ecu was seeing boost.
kman456 is offline   Reply With Quote
Old 12-15-2013, 03:14 PM   #16
Junior Member
iTrader: (3)
 
Join Date: Mar 2008
Posts: 124
Total Cats: 2
Default

Most folks, including myself do not intercept the MAF when using the FIC6 on a Miata. It simply isn't required under 12 psi with the exception of a small annoyance if you are recirculating your BOV.

If you do intercept, there are some adjustments to be made to account for some 'voltage drop' from what I have read. I didn't intercept mine, so I cannot help you there. There is an old thread on miata.net that describes how one person successfully managed it

You can PM me and we can exchange phone #s and I'll try to see if I can help. I was given a method of setting up my FIC that has worked well for me. Setting it up as they describe in the instructions was not possible on my 2000. The other method is simpler anyhow. I run about 10 psi on my car and have been using the FIC for a couple of years. The FIC is very easy to adjust and has been dead reliable. I love the fact that idle adjustment is a non-event and my AC and cruise control work as well as when the car was stock.
fwman1 is offline   Reply With Quote
Old 12-15-2013, 07:27 PM   #17
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Quote:
Originally Posted by kman456 View Post
So please can someone point me in the right direction.
Sure i'll point u to the right direction.

MegaSquirt-II EMS System - SMD PCB3.57 w/ Black Case DIYAutoTune.com
triple88a is offline   Reply With Quote
Old 12-15-2013, 07:58 PM   #18
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

i just read a thread on miata.net that you cant retard timing on FIC with a vvt BP engine?

any truth to this?
kman456 is offline   Reply With Quote
Old 12-15-2013, 10:53 PM   #19
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: grants pass oregon
Posts: 81
Total Cats: -25
Default

Fixed it. FIC ignition retarding and VVT don't mix. Set all cells to 0 and she took off fully boosting bumped up fuel 10% to get AFR to 11.5 at WOT
kman456 is offline   Reply With Quote
Old 12-16-2013, 12:25 AM   #20
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

All cells? U mean for the timing?
triple88a is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 09:36 PM
Turbo 1995 Miata Low mileage Clean Tekel Cars for sale/trade 29 02-05-2016 05:16 PM
starting issue Johnny Tater Engine Performance 3 09-23-2015 07:10 PM
Project DDoS: '99 "Budget" boost build ProjectDDoS Build Threads 1 09-09-2015 02:52 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:44 PM.