Need help with turbo - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 04-07-2009, 02:44 AM   #1
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Fremont, CA
Posts: 12
Total Cats: 0
Default Need help with turbo

I have a airesearch m10 on a 94. Since last week it started pouring out white smoke and oil straight to the ground out of the exhaust. I rebuilt the turbo and it is still doing it. I am definitely confused and don't know where to look.
dainbramaged is offline   Reply With Quote
Old 04-07-2009, 05:38 AM   #2
I'm Miserable!
iTrader: (33)
 
Join Date: Jan 2009
Location: San Jose, CA
Posts: 1,066
Total Cats: -3
Default

Check your oil lines, is the return oil line pointing down? its gravity feed.
I had this same problem when i installed my dsm 16g turbo. different turbo but all turbos are mounted the same way. I would shoot out white smoke and oil and wondered wtf i did wrong cuz, i had everything hooked up right i just didnt have the turbo clocked right my oil return line was horizontal instead of vertical but pointing down.
railz is offline   Reply With Quote
Old 04-07-2009, 10:51 AM   #3
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Maybe its not the turbo that was the problem. Could be a blown head gasket.
Saml01 is offline   Reply With Quote
Old 04-07-2009, 11:12 AM   #4
Junior Member
iTrader: (7)
 
Join Date: Aug 2006
Location: Binghamton, NY
Posts: 448
Total Cats: 1
Default

Don't forget to check the plugs. They tell all sorts of stories.
--Alex
AlexO35 is offline   Reply With Quote
Old 04-07-2009, 07:55 PM   #5
Newb
Thread Starter
 
Join Date: Feb 2009
Location: Fremont, CA
Posts: 12
Total Cats: 0
Default

My turbo is clocked with the drain down. The more I thought about it the more I thought could it be rings?
Thanks guys
dainbramaged is offline   Reply With Quote
Old 04-07-2009, 08:18 PM   #6
Newb
 
Join Date: Jul 2008
Location: San Jose, CA
Posts: 44
Total Cats: 0
Default

Check your seals. Sometimes turbo clocked the wrong way will damage them, sending oil down your intercooler pipe and so on.
Chris_Himself is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
ISO 1.6 turbo cast iron manifold cale saurage DIY Turbo Discussion 16 10-01-2015 12:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:39 AM.