Immobilizer/key genius needed ('05) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 12-26-2013, 07:40 PM   #1
Newb
Thread Starter
 
Join Date: Dec 2013
Location: East Bay, CA
Posts: 6
Total Cats: 0
Default Immobilizer/key genius needed ('05)

I have searched, and taken the car to a dealer, and called other dealers, and bugged the PO...all to no avail. If anyone has seen this same problem or has ideas about diagnosis (or just wants to confirm that I should just get a Megasquirt and forget it), please chime in.

I have the jackknife key ('05 MSM) and it works just fine, turns car on, runs, yadda yadda. Car is on the stock ECU. I have two cut keys with chips in the heads that the PO said he got from a dealer and even checked them at the dealer to make sure the car ran with them and it did. I hate the silly jackknife key and want to use just the smaller ones but they now kill the engine after firing it and the security light flashes.

Went to a dealer who couldn't get the car to go into programming mode but did, after I made a stink about sitting there for 2 hours w/no communication about what they were doing (or not doing), give me the code. So I have the code for my immobilizer, and the programming procedure, but the car won't go into programming mode--with any key, including my working jackknife key. The tech at the dealer couldn't get it to go into programming mode, my husband who's a Honda mechanic couldn't, and I couldn't (so probably not user error). When attempting the programming procedure, the security light illuminates and just stays lit indefinitely.

I tried putting my working jackknife key an inch away from my ignition and using one of the cut (and previously working, according to PO) keys in the ignition and it killed the engine. I called another dealer to see if I could get one cut key w/a chip in the head, and the parts guy there told me only jackknife keys can be used on my car (?) & that they would charge me $160 to diagnose then $208 for another jackknife key. No thanks.

WTF? 1) Can a cut key w/chip be used for my car or not? 2) If so, how did the ones I have work and now they don't? 3) Other input?

Argh. Frustrating. I want to address this now so I don't lose the one working key (jackknife) that I have and be really f-ed.

Thank you!!
Shan05 is offline   Reply With Quote
Old 12-27-2013, 04:29 AM   #2
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 200
Default

The two extra keys probably never worked.

I've had a similar situation once - the module would not go into programming mode, or rather, it would, and the engine would start with the new key, but once you killed it, it forgot the new key and wouldn't start again.
Reverant is offline   Reply With Quote
Old 12-27-2013, 02:49 PM   #3
Newb
Thread Starter
 
Join Date: Dec 2013
Location: East Bay, CA
Posts: 6
Total Cats: 0
Default

Quote:
Originally Posted by Reverant View Post
The two extra keys probably never worked.

I've had a similar situation once - the module would not go into programming mode, or rather, it would, and the engine would start with the new key, but once you killed it, it forgot the new key and wouldn't start again.
I know that the mid-2000's Mazda immobilizer systems are known for being doggie doo and I may just have to accept that my options are to keep using the jackknife or to go to MS3/MS3x. Rev, you're the perfect person to ask: w/one of your MS3's (3, 3x, whatever is recommended), can I use just a simple cut key, or put in a kill switch/start button? Since I'm in CA the plan is to eventually go to a MS but keep the stock ECU functional to switch to for smog.

Can anyone confirm or deny that a '05 Miata w/jackknife key can't use a non-jackknife key (sounds like stealership bs to me)?
Shan05 is offline   Reply With Quote
Old 12-27-2013, 02:57 PM   #4
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,468
Total Cats: 785
Default

Is this an 05 thing? My 04 MSM doesn't have a jacknife, but i seem to have ended up with like... 8 different keys because there were immobilizer issues with the Hydra, or so that's what the PO told me.
concealer404 is online now   Reply With Quote
Old 12-27-2013, 03:03 PM   #5
Newb
Thread Starter
 
Join Date: Dec 2013
Location: East Bay, CA
Posts: 6
Total Cats: 0
Default

Quote:
Originally Posted by concealer404 View Post
Is this an 05 thing? My 04 MSM doesn't have a jacknife, but i seem to have ended up with like... 8 different keys because there were immobilizer issues with the Hydra, or so that's what the PO told me.
I'm jealous. You have the opposite problem to mine
Shan05 is offline   Reply With Quote
Old 12-27-2013, 04:58 PM   #6
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,468
Total Cats: 785
Default

Quote:
Originally Posted by Shan05 View Post
I'm jealous. You have the opposite problem to mine


Right...

Well that said, the immobilizer never worked right with Hydra. The car always thought it was stolen or something. The light constantly flashed. PO said you couldn't use the factory key with the Hydra, but he was wrong, so i don't know who told him that.

Digging through the car after the Haltech install, i found 2 more factory keys and 2 more copied blanks.

So... 4 factory keys, 4 blanks. Factory keys work fine. Immobilizer light isn't flashing anymore.

No idea what the ****.
concealer404 is online now   Reply With Quote
Old 12-27-2013, 05:40 PM   #7
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 200
Default

Quote:
Originally Posted by Shan05 View Post
Rev, you're the perfect person to ask: w/one of your MS3's (3, 3x, whatever is recommended), can I use just a simple cut key, or put in a kill switch/start button?
Yes, you can.
Reverant is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 07:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:34 PM.