Link chip just took a dump - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-04-2011, 10:37 PM   #1
Newb
Thread Starter
 
Join Date: Dec 2004
Location: Texas
Posts: 33
Total Cats: 0
Default Link chip just took a dump

Well apparently my Link chip just took a dump. Went out to drive the car and it will fire but will not stay running. Miss fires and is pouring fuel. Specs on the car.
91 1.6
Link full standalone
RX7 550's
Greddy turbo
LMC1

Looked at the FM site and don't see chips listed anymore so I hope I'm not f'ed with this. Any help will be greatly appreciated.
trackfiend is offline   Reply With Quote
Old 08-04-2011, 11:05 PM   #2
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,109
Total Cats: 518
Default

Can't help with the Link, but it's a good time to upgrade to MS, you won't regret it, and you should still be able to get some money for the Link, working or not. Haven't heard of one "taking a dump", so you might still be able to fix it.

FM now sells Hydra, since the Link has been outdated for a while, so you're not missing anything on their site, they just don't sell them anymore.
curly is offline   Reply With Quote
Old 08-05-2011, 03:33 PM   #3
Newb
Thread Starter
 
Join Date: Dec 2004
Location: Texas
Posts: 33
Total Cats: 0
Default

I was afraid of that. I had to replace the chip last time because it would not store any changes that were made. Ran the car Monday and it ran fine, then last night went out to start it and it's doing what I mentioned above. This sucks to have to replace the ecu right now because I don't have the money to use for that.
trackfiend is offline   Reply With Quote
Old 08-05-2011, 08:18 PM   #4
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,109
Total Cats: 518
Default

Anything else happen on that ride? Extra hot? Big bump? Launching the car?
curly is offline   Reply With Quote
Old 08-07-2011, 03:05 PM   #5
Newb
Thread Starter
 
Join Date: Dec 2004
Location: Texas
Posts: 33
Total Cats: 0
Default

Nothing out of the usual. It ran great was hoping to put it on the dyno next week and do some tuning.
trackfiend is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
1.6L extrude honed intake manifold kww502 Miata parts for sale/trade 9 10-09-2015 06:21 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:08 AM.