01+ header swap issue - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-29-2014, 09:25 PM   #1
Newb
Thread Starter
 
Join Date: Apr 2014
Posts: 6
Total Cats: 0
Default 01+ header swap issue

Hey not sure if this is the right place to put it, I recently got a p0421 CEL and ended up doing the 01+ manifold swap with racing beat extensions and welded bunge. However, it still throws the code, even after clearing it. Did I miss something?
mxamazing is offline   Reply With Quote
Old 07-29-2014, 11:07 PM   #2
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,174
Total Cats: 2,575
Default

yes. the fact that it could be the sensor and not the cat
18psi is offline   Reply With Quote
Old 07-31-2014, 11:14 AM   #3
Senior Member
 
Join Date: Sep 2013
Posts: 903
Total Cats: 59
Default

You need to move one of the O2 sensors downstream past the cat, IIRC.
Dunning Kruger Affect is offline   Reply With Quote
Old 07-31-2014, 06:02 PM   #4
Newb
Thread Starter
 
Join Date: Apr 2014
Posts: 6
Total Cats: 0
Default

Hey guys,

Thanks for the reply. The o2 sesnor is a new bosch sensor. I did move the downstream o2 behind the cat. I'm afriad that its the actual cat itself. After replacing the pre-cat I cant believe i still have to deal with this issue.
mxamazing is offline   Reply With Quote
Old 08-01-2014, 08:52 AM   #5
Elite Member
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,790
Total Cats: 128
Default

What year is the car and do you have emissions testing where you are?

Personally I'd just buy a testpipe or bust the insides out of the cat you have and run the antifouler but there's no emissions in FL to deal with.

http://www.summitracing.com/parts/rn...3OehoCNf7w_wcB
pdexta is online now   Reply With Quote
Old 08-08-2014, 07:14 PM   #6
Newb
Thread Starter
 
Join Date: Apr 2014
Posts: 6
Total Cats: 0
Default

The car is a 2000, the pre-cat was toasted when we pulled it out. did the 01+ header swap and rerouted the o2 sensors.. still throws the code.... probably the most frustrating thing ever. I live in california
mxamazing is offline   Reply With Quote
Old 08-12-2014, 08:39 PM   #7
Junior Member
iTrader: (4)
 
Join Date: Mar 2006
Location: San Diego, CA
Posts: 67
Total Cats: 4
Default

The precat usually goes to crap when the coil packs are failing on NB1s. Might want to try replacing those first, or upgrade to the Fab9 COPs. Otherwise you're just crapping up another good cat. It doesn't take much.
RunninOnEmpty is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Noob to Miataturbo from MA JxPhan Meet and Greet 3 10-02-2015 03:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:54 PM.