91 NA idles then chokes - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-16-2013, 02:00 AM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: Sioux Falls, SD
Posts: 55
Total Cats: 1
Default 91 NA idles then chokes

Okay I typically dont do "please help me i dont know what to do" threads but I want to be able to drive my car a bit this summer. Pretty much I picked my miata up last year and was basically stripping it to the bone for autox, but with bar tending and classes I havent had much time to work with it. When I originally got it I was having some minor idle issues but after replacing fuel filter, plugs, wires, etc I have got a consistant idle for the most part. My issue now is that it will choke and die if I give it any gas, but if I slowly hand turn the TB I can rev it up fine. I have left it idle after start up and it sits fine but sometimes it needs a shot of ether to get going, which after it still idles fine and isnt choppy in any way. The only mods that are done are a 4-2-1 header and straight pipe exhaust (was guessing this might cause an emission problem with the 02 sensor and bog it down but the 02 is early enough this shouldnt matter). Sorry if this is too much rambling but its just upsetting sitting in my garage tinkering with little things all day and still getting no where. Any help is appreciated and I already have checked countless posts using the search which most didnt seem to give me any answers other than the CAS (which would be a long shot in my case I think). Thanks guys

Last edited by Dolsiac; 05-17-2013 at 02:38 AM.
Dolsiac is offline   Reply With Quote
Old 05-17-2013, 01:06 PM   #2
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: Sioux Falls, SD
Posts: 55
Total Cats: 1
Default

Had some time this morning and have been continuing to try and figure out where I went wrong. As of today I cannot even get the car to idle, with a shot of ether she burps and dies off again. From this id say I have sufficient spark, and I still smell reminiscent fuel as if she was flooding after about 5-8 seconds of cranking. Havent done a volt test on fuel pump but pulled it out in case I have to go that route, I still dont think that could be it either since it was idling fine a few days back. So pretty much as of now the car wont start period but still turns over and it does have spark. I will continue to check more wiring areas and grounds as well. Any help is appreciated, and if I cant get an answer here I may have to get one of the veteran Miata owners at the auto x meet this weekend to stop by and have a look.
Dolsiac is offline   Reply With Quote
Old 05-17-2013, 03:09 PM   #3
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: Sioux Falls, SD
Posts: 55
Total Cats: 1
Default

Well I got her to fire up long enough to take a quick vid of idle and when the car stalls. First video is just plain idle, and second is when I give it a bit of throttle and it dies. Other than that I did find my 30a Head fuse was blown so replaced that, and am guessing the overall problem may be an electrical issue. Wont have time to work on it for a bit but will continue troubleshooting soon.


Dolsiac is offline   Reply With Quote
Old 05-17-2013, 03:16 PM   #4
Senior Member
 
Join Date: May 2011
Location: Pennsylvania
Posts: 1,119
Total Cats: 33
Default

since it has a MAF, check for a leak somewhere between your MAF and the throttle body. might be sucking in extra lung juice
sometimes the plastic seams split on the intake ductwork.
supercooper is offline   Reply With Quote
Old 05-17-2013, 03:51 PM   #5
Junior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Sherwood, AR
Posts: 105
Total Cats: 0
Default

No it has an AFM and it seems like its dying, or at least it's doing what mine did when it was on the way out. Once it dies all the way the symptom will be - cranks up but dies immediately.

Last edited by Red91; 05-17-2013 at 04:01 PM.
Red91 is offline   Reply With Quote
Old 05-17-2013, 04:02 PM   #6
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: Sioux Falls, SD
Posts: 55
Total Cats: 1
Default

I did quite a clean down on the AFM right away after I got the vehicle. So red91 your pretty much saying that the inlet that lets air through is not opening correctly and thus choking the engine the moment that more fuel is pushed in? I will take it apart this weekend and see if I cant double check if it is working or not. I am guessing the best way would be to remove it directly from the intake piping so it can still read air but the TB will actually not be deprived by the AFM staying closed. Thanks guys ill let you know how it goes.
Dolsiac is offline   Reply With Quote
Old 05-17-2013, 04:05 PM   #7
Junior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: Sherwood, AR
Posts: 105
Total Cats: 0
Default

It could be the signal it's sending or the dreaded flapper. Taking mine apart in the first place was what killed it. Seems they're fine if you just leave them be, in my exp anyways. I do not miss my AFM days. Good luck!

Oh and you can't test an afm with the piping open, there has to be a vacuum to move the flap or it will still just start and die. If you have a na miata buddy with a working AFM you might put his on your car for a min and see what it does. If the afm is fine it's prob a vacuum leak somewhere between it and the TB like cooper was saying.

Last edited by Red91; 05-17-2013 at 04:18 PM.
Red91 is offline   Reply With Quote
Old 05-17-2013, 05:43 PM   #8
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: Sioux Falls, SD
Posts: 55
Total Cats: 1
Default

Well got the AFM off so just have to wait until tomorrow's auto x event and see if any NA's will bum me an extra haha. Thanks for the help and ill update once im able to test another on it. On a side not before I took it off I tried to fire it up and it wouldnt ignite without the spray of ether, if this is all because of the AFM I will be pushing forward my motor swap sooner than before this motor blows haha.
Dolsiac is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM
mslabs MS2 - Idle control issue ndragun MEGAsquirt 0 09-20-2015 11:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:16 PM.