Changed motor mounts, now car stalls when revs drop? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 06-26-2011, 11:50 AM   #1
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Sep 2009
Location: Royal Oak Michigan
Posts: 756
Total Cats: 67
Default Changed motor mounts, now car stalls when revs drop?

Car:
2002 Miata 1.8 BEGI s4 turbo kit. Xede piggy back.

Story:
Car drove fine, started fine, returned to idle perfectly. I changed my motor mounts as one of them was ripped in half.

I had to lift the engine quite high to remove the mounts and during this time I suspect something went wrong.

Now when i start the car it starts and idles fine but will not return to idle properly after revs. It will stall if I rev high enough to create any positive pressure in the system. When I come to a light, if i don't baby it down from rev's, she will stall. I did find that if the AC is active the extra timing or dashpot will cause a normal recovery.

My vacuum is at neg 16-17 PSI at idle and i was boosting in the 11.5 and it's down to a consistent 9-10.

I've been looking for vac leaks? Not sure where else to head with this one?
miatauser123 is offline   Reply With Quote
Old 06-27-2011, 10:58 AM   #2
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Sep 2009
Location: Royal Oak Michigan
Posts: 756
Total Cats: 67
Default

Anything? Just last night I started it and the idle sagged down to like 500 with -8 on the gauge in the 10afr's.

Anyone know of a sensor that would cause similar problems? It's so subtle that it's hard to track down :(
miatauser123 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 09:36 PM
1991 Turbo Miata partout tottestad Miata parts for sale/trade 18 09-14-2015 08:52 PM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM
WTB T25/T28 flanged turbo ASAP JesseTheNoob WTB 4 09-11-2015 02:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:23 AM.