compresion fail... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-22-2010, 05:36 PM   #1
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2006
Location: MA
Posts: 885
Total Cats: 2
Default compresion fail...

finally getting around to getting my car running again after a year and a half. when i left it, it was smoking pretty badly when running at almost all times. oil smoke.

turbo DEFINITELY needed a rebuild as the shaft play was bad enough to have the compressor housing have some light scoring from the wheel, so that's been sent out, but i was hoping the motor itself was ok. finally gt around to doing a compresion check today. i was happy until i hit cylinder 4...

as you can see form my sig, it's a 1.6 greddy based setup with a begi DP and MSI. ran great at 14 - 15 psi, but the urge to crank it up a bit, (to 17'ish, maybe a little more) may have been thr straw that broke the camel's back...

could be valve related, or ring related, i suppose... might as well pull the head next time i can work on it and see what's up.

FML.

Name:  c0a64fa7.jpg
Views: 1
Size:  27.8 KB
devin mac is offline   Reply With Quote
Old 05-22-2010, 05:38 PM   #2
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

Ouch. I drew the line at 15 psi with my Greddy. Upgrade to a 1.8!
Bryce is offline   Reply With Quote
Old 05-22-2010, 05:40 PM   #3
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

Did you have a dual feed fuel rail? I'm guessing detonation caused the damage in #4.
dustinb is offline   Reply With Quote
Old 05-22-2010, 05:46 PM   #4
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2006
Location: MA
Posts: 885
Total Cats: 2
Default

negative on the dual feed. i hadn't thought of that though.. 1 - 3 plugs looked pretty rich, though, and similar to 4... i didn't see anything BLATANTLY indicating det on 4... btu i guess i'll get a picture of it when i yank the head next weekend.
devin mac is offline   Reply With Quote
Old 05-22-2010, 05:51 PM   #5
Senior Member
iTrader: (8)
 
Join Date: Feb 2009
Location: Jax, Fl
Posts: 907
Total Cats: 0
Default

well if ya need anything I've got some stock internals and new rings I didnt use LMK
johnmatt is offline   Reply With Quote
Old 05-22-2010, 05:55 PM   #6
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2006
Location: MA
Posts: 885
Total Cats: 2
Default

i'll keep that in mind. pm me a price shipped so i can run down my options this week and make a decision?
devin mac is offline   Reply With Quote
Old 05-22-2010, 06:02 PM   #7
Senior Member
iTrader: (8)
 
Join Date: Feb 2009
Location: Jax, Fl
Posts: 907
Total Cats: 0
Default

What do you think you might want? I've got a set of rods with good pistons attached and the bearings look good still you could possibly reuse them
johnmatt is offline   Reply With Quote
Old 05-22-2010, 07:20 PM   #8
Junior Member
iTrader: (1)
 
Join Date: Oct 2008
Location: Palm Harbor FL
Posts: 332
Total Cats: 4
Default

when my car leaned out on nitrous valve was the first to go. i lucked out and bought a "replacment head" on ebay for 150 bucks and it showed with hks 256s in it 14.9whp gain with no other mods.
1slowna is offline   Reply With Quote
Old 05-24-2010, 11:49 AM   #9
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2006
Location: MA
Posts: 885
Total Cats: 2
Default

looks like the plan is to pull the head and hand it over to my fiance's dad so he can bring it to a machine shop he works with (he owns a used import dealership) to check out. if there's anything off-looking, they'll refresh it with oem-spec stuff and i can slap it back on with some arp studs and check the comp again (assuming the cylinder bores look ok when i pull it). if it still doesn't show decent comp, then i'll build the bottom end with some m-tuned or belfab rods.

my guess is the more likely culprit is the valve guides/seals, since all my plug wells had oil in them that looked like it had been forced through the o-rings on the valve cover side, and adding a tbsp or so of oil to cyl 4 yielded a 120 rather than the 90 i got when i tested it dry.

thoughts on this plan?
devin mac is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
early block in a 99 never been done Hahnlsquid Engine Performance 5 04-16-2014 01:18 PM
04 engine vvt into 90. Need fuel and timing base map. 90 Turbo MEGAsquirt 18 09-07-2012 10:10 AM
1.6 and 1.8 stuff 90 Turbo Miata parts for sale/trade 1 09-07-2012 01:30 AM
Lossing oil, Dip stick shoot out of its holder after throttle punch. Related? 90 Turbo Engine Performance 23 05-01-2012 06:33 PM
Blue Smoke - Lots of it at start up. stops when warm zeroox Prefabbed Turbo Kits 26 02-04-2012 05:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:36 AM.