Matt's Car - Had a problem...or 4!!! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-31-2009, 03:12 PM   #1
Junior Member
Thread Starter
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default Matt's Car - Had a problem...or 4!!!

Let the picture speak for itself

Name:  IMG_1183.jpg
Views: 1
Size:  139.0 KB

mikef85 is offline   Reply With Quote
Old 01-31-2009, 03:15 PM   #2
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

So, I'm guessing detonation city ruined this motor? More close up pics of the pistons please. I wanna run more boost.
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 03:16 PM   #3
Junior Member
Thread Starter
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default

No Detonation, just overpowered the rods

EDIT: Battery in camera is dead. Pistons look really good, as well as the rings.

He was putting 273hp to the ground.
mikef85 is offline   Reply With Quote
Old 01-31-2009, 03:29 PM   #4
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

Quote:
Originally Posted by mikef85 View Post
No Detonation, just overpowered the rods

EDIT: Battery in camera is dead. Pistons look really good, as well as the rings.

He was putting 273hp to the ground.
Don't say that. That's not what I want to hear.
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 03:32 PM   #5
Junior Member
Thread Starter
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
Don't say that. That's not what I want to hear.
Haha, I would actually feel comfortable using these pistons in another car. They really look that good.

I expected the rings to fail first, but they were excellent as well.

The worst thing about pistons was a slight bit of carbon build up on one of them.



Where's Waldo?
mikef85 is offline   Reply With Quote
Old 01-31-2009, 03:38 PM   #6
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

Meh, I'm gonna tell myself that detonation bent those rods. Who's Waldo? What kind of AFR's did he tune for in full boost? I still think detonation did it.....
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 03:41 PM   #7
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

And did it bend all four rods? I can tell two are bent from the pics. Did he have a coolant reroute? When did this happen? At 7K RPMs 25 minutes into a track session or what? What timing map was he running?
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 03:42 PM   #8
Junior Member
Thread Starter
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
Meh, I'm gonna tell myself that detonation bent those rods. Who's Waldo? What kind of AFR's did he tune for in full boost? I still think detonation did it.....
Not sure on AFR's. The guys up at Bell did the tuning.

Fine Pat, for you piece of mind we will call it detonation.

You have never did one of those where's waldo pictures?

Note: No signs of detonation were seen.
mikef85 is offline   Reply With Quote
Old 01-31-2009, 03:44 PM   #9
Junior Member
Thread Starter
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
And did it bend all four rods? I can tell two are bent from the pics. Did he have a coolant reroute? When did this happen? At 7K RPMs 25 minutes into a track session or what? What timing map was he running?
He did have a coolant reroute. This happened after a 6th gear highway pull. Not sure on timing map. But, I am sure Bell is not going to send out a tune that is so aggresive it will kill a motor....surely.
mikef85 is offline   Reply With Quote
Old 01-31-2009, 03:45 PM   #10
Guest
iTrader: (6)
 
Join Date: Sep 2007
Location: Vaughan, On, Canada
Posts: 1,092
Total Cats: 0
Default

Let me know if you need rods as I only have 5 sets left.. I can hook you up and ship them out next week. 270hp is a lot of power for an NB motor in **MY** opinion.
M-Tuned is offline   Reply With Quote
Old 01-31-2009, 03:47 PM   #11
Junior Member
Thread Starter
iTrader: (7)
 
Join Date: Apr 2007
Location: South of Houston, Texas
Posts: 329
Total Cats: 0
Default

Quote:
Originally Posted by [email protected] View Post
Let me know if you need rods.. I can hook you up and ship them out next week.
Thanks.

I already have all the parts for the rebuild though.

Pat, If it doesn't look like all four rods are bent it is an illusion....they are bent. Some more significantly then others.

EDIT: Dang it, 300 posts.
mikef85 is offline   Reply With Quote
Old 01-31-2009, 03:47 PM   #12
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,362
Total Cats: 1,323
Default

Wow. This really makes me want to measure my rods.
Savington is offline   Reply With Quote
Old 01-31-2009, 03:49 PM   #13
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

Quote:
Originally Posted by mikef85 View Post
Thanks.

I already have all the parts for the rebuild though.

Pat, If it doesn't look like all four rods are bent it is an illusion....they are bent. Some more significantly then others.
Ah, gotcha. Still strange it failed the way it did. All four at the same time.
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 03:52 PM   #14
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

Funny, cause I almost turned up the boost earlier after riding around this morning.
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 03:56 PM   #15
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

Quote:
Originally Posted by mikef85 View Post
EDIT: Dang it, 300 posts.
Post *****.
patsmx5 is offline   Reply With Quote
Old 01-31-2009, 04:16 PM   #16
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: VIRGINIA BEACH, VA
Posts: 6,020
Total Cats: 175
Default

Quote:
Originally Posted by Savington View Post
Wow. This really makes me want to measure my rods.
I tried to measure my rod once... but the ruler was only 12" long.

As for the broken motor... that's what you get for using a homosexual fuel rail.
samnavy is offline   Reply With Quote
Old 01-31-2009, 05:42 PM   #17
Newb
 
Join Date: Apr 2008
Location: Houston, Texas
Posts: 42
Total Cats: 1
Default

This is my car and there wasn't any detonation ever much less anywhere near the time we started hearing the cool ticking noises. Bryce and I were driving (Spiritedly) from Houston to Fredricksburg to the Texas Miata Roundup. Bryce did a few 80mph-140mph pulls (maybe I'll get him to pay for half the build) and when we slowed to exit the freeway we heard the ticking. We were pretty close to BEGi so I called Stef and she told us to bring it by. My Dyno chart is on here somewhere but if I remember correctly at full boost (13psi) my AFRs are around 12.6 I think. Don't quote me. The Gay fuel rail is a new addition and wasn't on the car when the rods bent. Corky told me not to tune past 12psi on stock internals but I insisted on 13psi so I got what I deserved, a BadAss engine build. Don't tell my wife, she still thinks that it was an accident!
mattkock is offline   Reply With Quote
Old 01-31-2009, 07:50 PM   #18
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

so this is where I sum up some details:

2003 10:1 compression motor
13 psi
12.6 AFR
GT2860
Xede controlling it.

also I'll note here that my car pings ever so slightly if I use too aggressive timing at 10 psi... on 93 pump gas...
y8s is offline   Reply With Quote
Old 01-31-2009, 11:17 PM   #19
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

could have been bad gas.... or diesel...
Arkmage is offline   Reply With Quote
Old 01-31-2009, 11:43 PM   #20
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

hurry, everyone in texas blow up their stock motor so hustler can't flex on you. lol
hustler is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
[CT] 1999 Mazda Miata 10th Anniversary Edition - $5800 Jike Spingleton Cars for sale/trade 3 09-20-2016 05:33 PM
FS/FT: 03.5 Mazdaspeed Protege leatherface24 Cars for sale/trade 15 10-16-2015 12:35 PM
Squiblez 1996 Montego blue Squiblez Build Threads 2 09-22-2015 11:17 AM
Twitchy car (tail happy problem) bigben Race Prep 16 09-11-2015 04:41 PM
WTB parts for HPDE car Voltwings WTB 5 09-11-2015 09:23 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:55 PM.