Oil Burning? Gaskets giving out? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 11-18-2010, 12:37 PM   #1
Newb
Thread Starter
 
Join Date: Feb 2010
Location: Miami FL
Posts: 14
Total Cats: 0
Default Oil Burning? Gaskets giving out?

Hey ,

everyone well i just resealed my intire engine basically and i even had a head job done. I have 190 down all cylinders but for some reason i am having insane oil pressure, the new seals on the crank shaft gave out completly, and so much oil build up that 2 of my plugs went out as well, i am burning insane clouds of oil and leaking pretty bad. I have a greddy kit boosting 5 pounds, the leak usually starts once i am stopped.

Any advice?? PLEASE HELP

Thank you!

1990 Miata
1.6l
Mishimoto radiator
Mishimoto Fan shroud
Exedy stage 1 clutch and seals
Timing belt
Greddy Bolt on turbo kit
Cx racing intercooler and BOV
95,455 miles
Resealed entire engine
Head gasket
190 compression down the line
Tokico shocks and springs
Bucket seats
Nb dash swap
Hardtop
acusido2 is offline   Reply With Quote
Old 11-18-2010, 02:21 PM   #2
Elite Member
iTrader: (2)
 
fooger03's Avatar
 
Join Date: Jan 2009
Location: Columbus, OH
Posts: 4,133
Total Cats: 188
Default

I am going to put about as much time and effort into answering this post as you put into describing your problem to us:

You should probably...

...damn, I just ran out of time and effort.
fooger03 is offline   Reply With Quote
Old 11-18-2010, 02:25 PM   #3
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Check your turbonator shaft for play. Use English next time you post.
hustler is offline   Reply With Quote
Old 11-18-2010, 02:29 PM   #4
Elite Member
iTrader: (6)
 
Join Date: Nov 2007
Location: Southlake,Texas
Posts: 3,251
Total Cats: 17
Default

It sounds like you failed at "resealing the intire engine"
Bond is offline   Reply With Quote
Old 11-18-2010, 02:52 PM   #5
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,684
Total Cats: 1,561
Default

Crank seals installed backwards? RTV plugging oil gallery? How many pounds of pressure is "insane"?

2 fouled plugs and clouds of smoke? Did you re-install valve stem seals? Did you install them correctly?

Did you replace the PCV valve or leave it out? Did you install it backwards?

Do you have a camera? Can you take some nudes of your sister for us? Or pictures of your engine compartment if nothing else...
sixshooter is online now   Reply With Quote
Old 11-23-2010, 11:35 PM   #6
Elite Member
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

+1 NUDES!
flounder is offline   Reply With Quote
Old 11-23-2010, 11:42 PM   #7
Junior Member
 
Join Date: Nov 2005
Location: Middletown, DE
Posts: 221
Total Cats: 1
Default

Quote:
Originally Posted by acusido2 View Post
Hey ,

everyone well i just resealed my intire engine basically and i even had a head job done. I have 190 down all cylinders but for some reason i am having insane oil pressure, the new seals on the crank shaft gave out completly, and so much oil build up that 2 of my plugs went out as well, i am burning insane clouds of oil and leaking pretty bad. I have a greddy kit boosting 5 pounds, the leak usually starts once i am stopped.

Any advice?? PLEASE HELP

Thank you!

1990 Miata
1.6l
Mishimoto radiator
Mishimoto Fan shroud
Exedy stage 1 clutch and seals
Timing belt
Greddy Bolt on turbo kit
Cx racing intercooler and BOV
95,455 miles
Resealed entire engine
Head gasket
190 compression down the line
Tokico shocks and springs
Bucket seats
Nb dash swap
Hardtop
You should have focused more on "resealing your intire engine" and less on getting a head job, therein lies your problem.

Last edited by Joseph B; 11-24-2010 at 12:48 PM.
Joseph B is offline   Reply With Quote
Old 11-24-2010, 12:20 PM   #8
Newb
Thread Starter
 
Join Date: Feb 2010
Location: Miami FL
Posts: 14
Total Cats: 0
Default

I did reseal the intire engine i had every gasket change, supposedly what the shop said was that there is corrrosion in the cylinder walls and lil gaps that are causing the blow back. they said its better if i just buy a new engine?
acusido2 is offline   Reply With Quote
Old 11-24-2010, 03:19 PM   #9
Junior Member
iTrader: (4)
 
Join Date: May 2009
Location: Novi, MI
Posts: 308
Total Cats: 1
Default

It sounds pretty obvious that you didn't do this yourself. So if the engine isn't actually "sealed" then why aren't you bitching at the shop that did the work to make it right?
Larimer is offline   Reply With Quote
Old 11-24-2010, 07:03 PM   #10
Newb
Thread Starter
 
Join Date: Feb 2010
Location: Miami FL
Posts: 14
Total Cats: 0
Default

No the engine did get resealed i witness them do it, the problem is the seals are giving out in a matter of a week or two, and its supposedly caused by back pressure
acusido2 is offline   Reply With Quote
Old 11-24-2010, 09:00 PM   #11
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Just because the shop did the work does not mean they did it properly. Install a real pressure gauge and report back with what "insane" pressures are.
triple88a is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:47 PM.