VVT Swap into 2000; Random Misfire Code - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-26-2016, 07:38 AM   #1
Newb
Thread Starter
 
Join Date: Mar 2014
Location: El Paso, TX
Posts: 8
Total Cats: 0
Default VVT Swap into 2000; Random Misfire Code

Thanks to Savington's awesome VVT swap thread, I decided to replace my NB1 engine with a blown head gasket with a low milage 2003 engine.

Amazingly, the car started right up with the stock (2000) ECU. Since I'm overdue for my state inspection (TX), I drove around to get my ready codes ready and no issues, save for an occasional high idle (1200-1300) at red lights. However, on my way to the inspection station I received a P0300 random misfire code... I noticed a strong drop in power/engine response right before the code, so perhaps if I let off the gas I could have avoided it.

Possibly pertinent info:
Using 2003 COPs
New NGK spark plugs (heat range 5 and gap checked to 1mm ~.04)
New Magnecor plug wires
Crank angle sensor measured within spec
Using 2003 injectors (possibly running rich?)
Installed DW200 fuel pump (too much fuel pressure?)
Running 91 Octane
VICS intake manifold
Stock intake

Any ideas what could have caused this?

If I can't figure it out, I'll just drive circles around the inspection station until the ready codes are good and cross my fingers. Afterwards the MS3 goes in, which should hopefully resolve the issue if it's due to the 2003 injectors causing me to run rich.

Thanks for your help!
thelarva is offline   Reply With Quote
Old 02-02-2016, 08:18 AM   #2
Newb
 
Join Date: Aug 2014
Location: MA
Posts: 26
Total Cats: 0
Default

I've had crank angle sensor issues give me the same problem. Partially sensor gap, and partially a likely wire issue in my case. Mines back in the shop right now after also throwing p0300 and p0303 (misfire in cylinder 3). Doing my homework on it it sounds like some also get the misfire code due to egr being clogged. It's intermittent at best.

As far as the injectors making it run too rich, I can't imagine that's really the problem. your talking 5cc over stock. So a 3% difference?

Where did the new engine come from? Been sitting? just working out kinks from not being used for a while maybe?
Nathan F is offline   Reply With Quote
Old 02-15-2016, 03:10 PM   #3
Newb
Thread Starter
 
Join Date: Mar 2014
Location: El Paso, TX
Posts: 8
Total Cats: 0
Default

Thanks Nathan for your reply. Since then things got better, then much worse. I installed my MS3 Basic and got that working pretty well (thanks to Rev helping me troubleshoot the install).

However, a few days after a long drive, I started experiencing some major misfiring to the point my engine was violently shaking and even started smoking... I'm not an expert, but those things are generally bad.

I suspected perhaps the coils (using 2003 COPs) and tested them in Tunerstudio. I am hearing a clear distinction in the difference between the rate of fire in bank #1 and bank #2, which is firing at half the rate of #1. I swapped COPs and either one that I hook up to bank #2 fires at half the rate. This makes me think I have an issue with the wiring, rather than the COPs. Does this sound correct? Unfortunately, I'm stationed away from home and don't have access to my multimeter to confirm this suspicion. Thanks for any advice you have.

thelarva is offline   Reply With Quote
Old 02-15-2016, 03:36 PM   #4
Newb
 
Join Date: Aug 2014
Location: MA
Posts: 26
Total Cats: 0
Default

I just fixed mine. Replaced the 99-00 setup with the fab9 lug and play. Just a guess, but wouldn't one bank sound different from the other since it fires 1&4 vs 2&3? I would imagine it has to do with the stroke timing of how long it takes from cyl 1 to reach full compression, vs cyl 4 reaching full compression. There are smarter folks here than me, though.
Nathan F is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Nb intake manifold, mazda comp mounts, oil cooler btabor Miata parts for sale/trade 0 12-16-2015 06:49 PM
Help me weed through the BS about NB fuel pumps vteckiller2000 Engine Performance 11 12-11-2015 02:54 AM
Fuel pump shuts off at low RPM ryansmoneypit MEGAsquirt 23 12-08-2015 10:29 AM
Head gasket layers question btabor Engine Performance 26 12-08-2015 03:49 AM
VICS 99-00 Intake Manifold nbdooey Miata parts for sale/trade 2 12-02-2015 06:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:24 AM.