[NB2] Low-beams not working (aftermarket HID setup) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 01-20-2015, 10:17 PM   #1
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default [NB2] Low-beams not working (aftermarket HID setup)

So I've had aftermarket HIDs since I've had the car. I had the occasional bulb go out and have replaced both ballasts at one time or another. But this is a new problem.

About 2 weeks ago, I went to turn the headlights on and the fogs/parking lights came in but no low-beams. I rocked the stalk a couple of times and the lights turned on. This has happened several times since. One time I tried revving the car up a bit and then turning them on and they fired off immediately. I was startin to suspect maybe a low-voltage issue either by a weakening battery or alternator.

Tonight they decided to stop working all together.

Parking lights work.
Fog lights work.
High-beams work.

Checked both headlight fuses under the dash- both good.
Checked headlight relay- it switched on/off when I pulled it while the lights were switched on.
Checked the HID kit relay- same as headlight relay: clicks on and off if I unplug/plug it in with the lights switched on.

I'm at a loss. I would drive to an audio shop and try some new components, but it's too dark now.

I did swap out one ballast- nothing.
Have a spare bulb, but unknown age condition and it's slightly cloudy, so probably bad.
Both bulbs were cloudy/hazy, but how could both go bad at the same time?


Halps?
Doppelgänger is offline   Reply With Quote
Old 01-20-2015, 10:22 PM   #2
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,163
Total Cats: 2,573
Default

replacement bulbs are 15 bux on ebay.
I'd loan you mine but shipping would probably cost close to what the ebay ones will cost.
18psi is offline   Reply With Quote
Old 01-20-2015, 10:35 PM   #3
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

Lol yeah.

I'm hoping the audio shop that carries HiD stuff will let me try swapping some components with just having to buy a whole kit.
Doppelgänger is offline   Reply With Quote
Old 01-21-2015, 02:50 AM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

Also check you have 12V going to the ballasts. The relay may click but that doesn't mean that the relay is still good.
Reverant is offline   Reply With Quote
Old 01-21-2015, 01:07 PM   #5
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

That's my #1 suspicion. On my lunch break I'll be running out to get a relay and bulbs.
Doppelgänger is offline   Reply With Quote
Old 01-21-2015, 06:38 PM   #6
Elite Member
Thread Starter
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

I replaced the relay (main issue) and found one of the bulbs out at the same time. I wonder if the relay killed the bulb. Anyway, new and two bulbs replaced and all is well.
Doppelgänger is offline   Reply With Quote
Old 01-22-2015, 02:50 AM   #7
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

Yay!
Reverant is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
WTB 90-97 miata low profile headlight kit DonPlatt WTB 0 09-25-2015 03:57 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:38 PM.